444 10bit HDR output from Vero 4K + NOT PERSISTENT

I have just received and installed a Vero 4K+ that has replaced a Vero 4K that I had. The Video stuttering I had with the Vero 4K has been fixed with the new gigabyte ethernet port on the Vero 4K+. But just like the Vero 4K the HDR output is 8 bit BT2020 with 4K content (using HDFury Vertex to verify). And so I modified my rc.local file (in the /etc directory) as instructed in a prior thread for the Vero 4K, and then made rc.local executable. Now after I reboot my Vero 4K+ a 4K HDR mkv file is played back at first in 444 10 bit BT2020. If I stop the playback and then restart it, or play a different 4K movie with HDR, the playback reverts to 444 8 bit BT2020. From that point onward the only way to get 10 bit playback is to reboot the Vero 4K+.

The line that I added to rc.local before the exit 0 command is echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr, the same line that I added and worked successfully with my Vero 4K. My new Vero 4K + has been updated to OSMC August 2018 2018.08-2. What am I doing wrong in setting the 444 10 bit HDR?

Hi there,

You seem familiar with SSH.

Can you revert those changes, and try this kernel: [TESTING] Vero 4K / 4K + video improvements. We plan to release these changes shortly, so it’s worth testing if you’re eager.Please disable HDR autoswitching as well.

Can you also confirm Adjust Refresh Rate is enabled and Display is set to 1080?

Cheers

Sam

I just installed the new kernel you suggested and disabled the HDR autoswitching on my Vero 4K+. I also confirmed that the Adjust Refresh Rate is enabled On start / stop and the display is set to 1080p 60 hz.

Inital impressions… it works!

I will do more testing and report back. Thanks.

2 Likes

Great – thanks for testing something that will be part of OSMC in the very near future.

Cheers

Sam

Hi

I’ve just received my Vero player, and I’m having issues with HDR.
Not sure if I should have started another thread, but I downloaded the ‘experimental’ firmware to see if would resolve my issues, and it made them worse.

I have a LG B7 OLED, and an Denon X2400H amp. Until I get my issues sorted I will be keeping the Vero connected directly to the TV to rule out any side effects with the amp.

I’m assuming my issues are that output is 8-bit instead of 10-bit because of the posterization I was getting using the vero instead of the built in player.
Not sure how to check the output settings from the Vero itself ?

Anyway I ssh’ed onto the vero box and downloaded and installed the firmware as per the instructions in the link.
I then set the display resolution to 1080p and and disabled HDR autoswitching.

Now when I attempt to play a 4K HDR videofile, the TV stops receiving a signal. I have to stop playing and the the vero GUI starts showing up again.
Now the interesting thing was this was happening sometimes when I was using the latest stable firmware too, but would work after the second attempt.

I’m playing my content from an NFS share over network.

Would appreciate any help, and happy to start a new thread or whatever.

Thanks,

Hi,

Can you provide a link to the page so we can check you tested the right improvements?
Make sure you disable HDR autoswitching in Settings and enable Adjust Refresh Rate.

Also try a fresh reboot with TV and AVR on first; to rule out an issue that can occur if you power on your Vero 4K + first.

Sam

Hi,

That was quick :slight_smile:
I used these instructions:

wget https://collab.osmc.tv/s/DKFOE1k8H4QuuCq/download -O /home/osmc/kernel.deb
sudo dpkg -i /home/osmc/kernel.deb
rm /home/osmc/kernel.deb
sudo reboot

I did do a fresh reboot too.
I’ve since reverted to the stable branch.
Although happy to try the whole thing again, and collect any logs, if you tell me how to do this.
I have connected the Vero box directly to the TV for the time being until this is resolved.

Thanks,

Please try it again. First connected to TV. If that works reconnect to AVR.

You can upload a set of logs via My OSMC after reproducing the proble

We’d like to get these changes in soon so your feedback will help.

Sam

OK, strange (but good). Worked with TV. I’m sure it wasn’t before. Playing at 2160p and no posterization (even though set to 1080p res in the video menu).

I’m going to try again with the AVR in a few minutes and get back to you.

OK.
So reconnected back to the AVR, and I’m getting the behavior I described in my original post.
So issue through amp only, with this latest firmware, otherwise works.
The AVR is Denon X2400H.
Where do I collect the logs from ?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thanks, I’ve uploaded the logs and the url is:

[EDIT]
I’ve removed the link to debug log, as the issue is resolved,.

Thank you. I can’t immediately see anything odd but will dig deeper.

Thanks.

[edit]
Just to rule out a few things (or not):

The HDMI cables seem good (the one between the Vero-AVR and AVR-TV), because I’ve used them both between the Vero and TV, and everything works fine.

As for the AVR; I have a PS4 Pro, which runs through the AVR, and HDR works fine with that: The PS4 Pro reports that HDR is supported at all listed frequencies (up to 60Hz).

Did you reboot the Vero after connecting it back to the AVR? If not, please try that.

Yes, I did reboot. I’ve tried it many times and after many reboots.

Did you try a different port on the AVR? I’d suggest trying the one the PS4 is connected to. Not all ports on the AVR (just like on some TVs) may support 4K.

1 Like

Thanks for the suggestion.

All the inputs on the AVR are supposed to support 4K HDR, but when I connected it to the one the PS4 is using, I started getting intermittent video with the HDR files (few seconds on and off), which made me suspect the cable:
So I’ve swapped out the HDMI cable that came with the Vero, with a similar length “Amazon Basics High Speed 2.0” HDMI cable, and connected to the original port I was using on the AVR, and it works perfectly now!

I decided to re-test the Vero cable direct to the TV, and in that setup it works fine too: Very strange :slight_smile:

So to summarize:
When using the “Vero supplied HDMI cable” connected to the AVR; HDR does not work or does not work properly, but when connected directly to the TV it is fine.
Weird. Would be interested on anyone’s thoughts on this, from a technical point of view (promise I wont’ be sensitive to any criticism of my AVR :wink: ).
At least the issue is resolved, with a different cable.
Many Thanks for your help.

1 Like

Maybe a splash of contact cleaner would improve things for that cable.

OK: So maybe just an issue with the contacts.

One other thing I noticed with this experimental kernel, is that it would occasionally revert to 8-bit with the HDR. This happened twice, and I think it was after it was powered off. A reboot was required both times.