480p output being scaled when it shouldn't be...?

Paging @grahamh as this might be in some way related to previous work done on getting unscaled SD video output and the “Use HDMI AVI signalling” option. (But it also might not :slightly_smiling_face: ).

Here’s a link to a small test video: https://we.tl/t-owZN8i9SeB

This is intended to test deinterlacing, but it’s also a useful way of spotting when there’s some scaling going on when there shouldn’t be. I’m playing it with hardware acceleration turned off, with the scaling set to Nearest Neighbour, and output resolution set to 480p/59.94.

As the video resolution is 720x480 and the output resolution is also set to 720x480, there shouldn’t be any scaling going on. But every few seconds there’s some distortion in the left wedge which strongly suggests there is some horizontal scaling happening - in other words, the output is not a pixel-perfect copy of the video, despite the resolutions being the same.

Setting scaling to Bilinear is more visually pleasing, but I think there’s still some stray scaling happening - the lines get more or less sharp at different moments.

Playing in hardware looks much the same as software + bilinear, but as there’s no way to turn off bilinear scaling in hardware I can’t be sure.

Could well be a Kodi issue, of course.

Link to some debug logs: https://paste.osmc.tv/pijejekese

I’ll have a look next week.

1 Like

Did you ever get a chance to take a look at this, @grahamh?

Only briefly. Been wrestling with 4.9 issues.

I’d like to resurrect this issue, as it’s still outstanding. Summary: given a 480i video and 480p output, for some reason the Vero is doing some scaling when it clearly shouldn’t be.

I tried playing my test clip on a
Raspberry Pi today. No sign of this problem, so there’s a good chance this is specific to the Vero 4K rather than a general Kodi problem.

Something I didn’t say before is that it clearly is a scaling issue of some kind. If the video is 480i and the output is 480p then switching the scaling method between bilinear and nearest neighbour shouldn’t make any visible difference at all. The fact that it does means there must be some stray scaling happening.

It would be interesting to know if the same problem happens with hardware playback. It’s hard to be sure because there’s no way I’m aware of to turn off bilinear scaling in hardware, and bilinear masks the effect.


So, could someone take a look at this, maybe…?

It’s on the list but there’s huge push to get 4.9 polished up with 3D and other stuff which is absorbing development time.