4k blue light but dead otherwise

Hi everyone,

Despite some similar topics here on the forum, I couldn’t find anything that helps me so I hope you’ll forgive me for creating a new entry.

My Vero 4K stopped working (as far as I can tell). The weird thing is that the blue light is on (!). However, there is no HDMI output whatsoever, and nothing through ethernet (cable shows as disconnected on switch). I tried two different ethernet and two HDMI cables (they work on other devices).
I created a recovery USB stick but nothing happens, nothing at all on HDMI. But, the blue light is on.

When I connect power, the red light comes on for an instance and then immediately changes to blue (the way it always did). Something else: connected USB devices still get power but e.g. I tried two external USB ethernet cards and that didn’t work either.

Except for HDMI and ethernet (I never set up wifi), is there another way of connecting to the device? (straight through USB? serial?)

It could well be that after 5 years of very intensive use, it’s finally decided enough is enough, in which case I’ll order a 4K+. But if there’s anything at all that I can try first, I’d like to!

Thanks in advance.

Did you try to re-install the Vero 4k with an SD card?

1 Like

Yes, I did! :slight_smile: Both SD card and USB stick (USB in both slots), but it doesn’t work no matter how I try it.

All that happens is this:
Red light lights up very briefly, and almost immediately changes to blue. This is why I think it must still be alive.

But - nothing on ethernet (as I mentioned before: switch doesn’t even recognise that cable is connected), nothing on HDMI out. I would reckon it’s dead, but for the blue light…

Please show a screenshot of the contents of the SD/USB.


Do you know which version of OSMC your installation is currently on?

It’s not possible to run commands on it anymore but the last time it was fully updated was before the hols, end of June. (stable branch)

Sorry for the late reply.

The device might be stuck in some boot loop. I could give instructions (as the device is out of warranty) on how to short eMMC pins where we could do a low level format or you could send it back to us for looking at, but there’s no guarantee it can be fixed



I PM’ed you but can understand you might feel it’s apt for the instructions to short the eMMC to appear in this thread. Or not. But thanks for everything anyway!


I’ve sent you a PM.

Indeed – I sent these instructions privately as I indeed don’t want users cracking open their case unless they really need to