4K Buffering Issue on Vero 4K+

Indeed.

Any new equipment in any of the powerline connected rooms added / changed recently?

Actually I have a TP-LINK AV2000 and after 2 months I went back to my trusted 100Mbit cable as the throughput of the powerline was fluctuating too much. Even so there were days where it was well above 100Mbit there were also times where it was far below.

Thanks for the late night responses chaps, I’m really grateful.

Ok, as far as new equipment there is nothing new in the mix.

Hanewin I am using version 1.2.36 (latest release)

I will post the show mount info as soon as my very awake and wild 2 year old lets me escape ;).

My only question is why would the egreat play them without hitch? Could it possibly have a bigger buffer so it isn’t effect by a sudden drop in connection speed?

I don’t know how which libraries the egreat is using for mounting the NFS folders. As indicated possible FSTAB based mounts would remove your issues.

Ok, I have started over, fresh install of OSMC, uninstalled and reinstalled hanewin and I have only set up one share for now for my 4K movies.

Result of Showmount;

osmc@osmc-Aloysius:~$ showmount -e 192.168.0.2
Export list for 192.168.0.2:
/UltraHD -public
osmc@osmc-Aloysius:~$

My iperf3

;

and my Hanewin exports file and Server screen;

I just cannot get my head around fstab so any suggestions are more than welcome and will put you on top of my Xmas list :slight_smile:

I am not sure if the -public switch is equal to allow all ranges as I before only have seen Hanewin users haveing the -range option. Maybe someone wiith a Hanewin can confirm.

Well I personally would try it via autofs (even so fstab should be similar).
Read this thread (second part)

Basically your /etc/auto.nfs.shares should look like this

/mnt/UltraHD 192.168.0.2:/UltraHD

When you have followed all the steps in the HowTo let us know if success or not, we then can troublehsoot.

1 Like

As soon as I get home I’ll give this a try. Thanks for your patience with me :grinning:

So after my first attempt this is what I am getting;

Line added at bottom as guide instructed

Then the share

Then the result
3

No doubt I am doing something wrong???

did you perform this

sudo systemctl restart autofs

Testing the config:
After you have made the changes restart autofs:

sudo systemctl restart autofs

To test if your mounts works execute:

ls -lah /mnt/<server1>/<share1>

you should see the files from your network share. If it didn’t work run

sudo systemctl stop autofs
sudo automount -f -v -d

to debug what’s wrong.

To exit if running automount, just do a CTRL-C. To restart the service once everything is working, either reboot or:

sudo systemctl start autofs

I had similar issues, see Mount nfs share synology

1 Like

I have tried that chap but I still get the error message. I’m wondering whether or not I should try the whole path of the share used by Hanewin??So instead of just mnt/UltraHD should I try “mnt/media/movies/ultrahd”??

i’m not familiar with hanewin. for me it was incorrect rights on the NFS share-directory for which I couldn’t access.

Maybe you can check it from telnet to the hanewin server to see how they appear.

you can also upload your log, but I’m not that experienced to read the log file

1 Like

This is how it appears. Its odd it shows the -public which is a flag used in Hanewin to give open access to the shared dir instead of it being passworded

osmc@osmc-Aloysius:~$ showmount -e 192.168.0.2
Export list for 192.168.0.2:
/UltraHD -public

i mean not showmount :slight_smile:

i looked at permissions on the folder on hanewin server. in my case it appeared like this:

D————-

Changed it with chmod 777 to

Drwxrwxrwx

And i could select it

1 Like

I am travelling so someone else need to try to help you for the time being.

Suggest to run the command with the -v switch as explained in the troubleshooting part to see what’s wrong.

Definetly the missing “-range” parameter on the hanewin is strange. But if it works from within Kodi than that should not be the problem

1 Like

Thanks for all your help guys but I’m starting to feel this is a little above my pay grade. Maybe its using Hanewin that is causing a problem but it is all I know.

For now I have the eGreat for my 4K collection its just a pain as I wanted it all on one box.

Hi,

Try disabling the public option, this is for WebNFS; which shouldn’t be required for kodi.

Thanks Tom.

1 Like

Hi Tom and thanks for taking the time to look at my issue.

So, in hanewin my share for my 4K folder is;

e:\movies\ultrahd -public -name:UltraHD

so it becomes e:\movies\ultrahd -name:UltraHD

Is that correct?

So what would I enter into sudo nano /etc/auto.smb.shares?

Sorry to be a pain, this really is another level for me :slight_smile:

Chris

This is my current showmount. Ignore the /HD entry, I will edit that later if this is successful

Export list for 192.168.0.2:
/HD -public
/UltraHD (everyone)

OMG !!!

2 Likes

Hi,

Sorry for delay in response, anyway I think you’ve worked out /etc/auto.smb.shares shouldn’t need any modification.

Has using autofs helped with the buffering at all?

Thanks Tom.

1 Like