4K Buffering Issue on Vero 4K+

Firstly thanks for looking at my post. I must mention I have basically no knowledge of using the command line other than using iperf3 earlier to test my speed so please forgive my lack of OSMC knowledge.

I have a Vero 4K and a Vero 4K+ (as of today) and on both devices, when streaming 4K movies from my PC via NFS (Hanewin) & Powerline (Netgear AV1200) they continuously buffer and stutter and become unwatchable. I have been using Hanewin for many years on several devices and am confident it is performing as it should.

I did manage to test my speed using iPerf 3 and the results ranged between 91 - 104.

I have tested the 4K files using attached storage they all play perfectly.

1080P content streams perfectly using the network.

To eliminate the powerline as the culprit I have an eGreat a5 here so I reconnected it using the same ethernet cable as my 4K+, attached to the same NFS share and all my 4K movies stream perfectly so I’m a bit baffled baffled.

Could this be a buffering issue? Going back to last Autumn I could watch 4K movies on my Vero using the same setup without fault. Has the buffer size changed? Is that a possibility?

Sorry if this post is a bit all over the place.

Many thanks



Do I understand that you only experience the problem on your 4K, and not 4K +?

How is the NFS share mounted?

For 4K, you may need to use an fstab mount due to the lower network throughput.
Are you playing the same files as before? 4K UHD rips have become more demanding as of late.


Hi Sam and thanks for the reply. I have exactly the same problem on the 4K and the 4K plus. I bought the 4K plus hoping it would solve the issue ;).

I am using Hanewin on my PC as the NFS Server. I have done for many years now. The software is always updated to the latest version. My media files are all on an internal hard drive on my pc. I have 3 separate shares on Hanewin.

The one in question is;

e:\media\movies\4K -public -name:4K

I did attempt to create an fstab mount but even with the very helpful walkthroughs I could not get it to work. Maybe Hanewin makes it more complicated or my folder structure causes an issue. Some of the files, Wonder Woman for instance, my wife and I watched it in glorious 4KHDR on my Vero back in October along with many other movies. ago and it played perfectly. Today the same file stutters and buffers. It just frustrates me as they play on the eGreat but I want rid of that box as the support is bloody awful (and I like the whole feel of OSMC).

Ok, so the limit here doesn’t seem to be the Vero4(k) Ethernet or Gigabit Ethernet interface but the throughput of the Powerline adapter.

Considering that values your current option is only fstab based mounts as the throughput you reach is really borderline for 4k (check the mediainfo of the 4k file to understand the required bandwidth).

I only can recommend to try it again. Either via fstab or autofs. Suggest you start with giving the hanewin version details and showmount output from the Vero.

As Powerline performance changes depending on external influences this could be easily the issue.

1 Like


Any new equipment in any of the powerline connected rooms added / changed recently?

Actually I have a TP-LINK AV2000 and after 2 months I went back to my trusted 100Mbit cable as the throughput of the powerline was fluctuating too much. Even so there were days where it was well above 100Mbit there were also times where it was far below.

Thanks for the late night responses chaps, I’m really grateful.

Ok, as far as new equipment there is nothing new in the mix.

Hanewin I am using version 1.2.36 (latest release)

I will post the show mount info as soon as my very awake and wild 2 year old lets me escape ;).

My only question is why would the egreat play them without hitch? Could it possibly have a bigger buffer so it isn’t effect by a sudden drop in connection speed?

I don’t know how which libraries the egreat is using for mounting the NFS folders. As indicated possible FSTAB based mounts would remove your issues.

Ok, I have started over, fresh install of OSMC, uninstalled and reinstalled hanewin and I have only set up one share for now for my 4K movies.

Result of Showmount;

osmc@osmc-Aloysius:~$ showmount -e
Export list for
/UltraHD -public

My iperf3


and my Hanewin exports file and Server screen;

I just cannot get my head around fstab so any suggestions are more than welcome and will put you on top of my Xmas list :slight_smile:

I am not sure if the -public switch is equal to allow all ranges as I before only have seen Hanewin users haveing the -range option. Maybe someone wiith a Hanewin can confirm.

Well I personally would try it via autofs (even so fstab should be similar).
Read this thread (second part)

Basically your /etc/auto.nfs.shares should look like this


When you have followed all the steps in the HowTo let us know if success or not, we then can troublehsoot.

1 Like

As soon as I get home I’ll give this a try. Thanks for your patience with me :grinning:

So after my first attempt this is what I am getting;

Line added at bottom as guide instructed

Then the share

Then the result

No doubt I am doing something wrong???

did you perform this

sudo systemctl restart autofs

Testing the config:
After you have made the changes restart autofs:

sudo systemctl restart autofs

To test if your mounts works execute:

ls -lah /mnt/<server1>/<share1>

you should see the files from your network share. If it didn’t work run

sudo systemctl stop autofs
sudo automount -f -v -d

to debug what’s wrong.

To exit if running automount, just do a CTRL-C. To restart the service once everything is working, either reboot or:

sudo systemctl start autofs

I had similar issues, see Mount nfs share synology

1 Like

I have tried that chap but I still get the error message. I’m wondering whether or not I should try the whole path of the share used by Hanewin??So instead of just mnt/UltraHD should I try “mnt/media/movies/ultrahd”??

i’m not familiar with hanewin. for me it was incorrect rights on the NFS share-directory for which I couldn’t access.

Maybe you can check it from telnet to the hanewin server to see how they appear.

you can also upload your log, but I’m not that experienced to read the log file

1 Like

This is how it appears. Its odd it shows the -public which is a flag used in Hanewin to give open access to the shared dir instead of it being passworded

osmc@osmc-Aloysius:~$ showmount -e
Export list for
/UltraHD -public

i mean not showmount :slight_smile:

i looked at permissions on the folder on hanewin server. in my case it appeared like this:


Changed it with chmod 777 to


And i could select it

1 Like

I am travelling so someone else need to try to help you for the time being.

Suggest to run the command with the -v switch as explained in the troubleshooting part to see what’s wrong.

Definetly the missing “-range” parameter on the hanewin is strange. But if it works from within Kodi than that should not be the problem

1 Like

Thanks for all your help guys but I’m starting to feel this is a little above my pay grade. Maybe its using Hanewin that is causing a problem but it is all I know.

For now I have the eGreat for my 4K collection its just a pain as I wanted it all on one box.


Try disabling the public option, this is for WebNFS; which shouldn’t be required for kodi.

Thanks Tom.

1 Like