Mount nfs share synology

Hi, just received my vero 4k+

Had already configured nfs on syno nas and worked with coreelec on h96pro+ with default nfs settings.

Now i want to connect with vero to same nfs share and it won’t let me connect into folder. Can only map main nfs share, see the shared nfs shares but can’t login.

Why is this nfs mapping works different from coreelec?

Maenwhile i’ve updated vero to december version.

Nas is running 6.2 and nfs 4.1

How are you mounting? Kodi shares, fstab or autofs? If fstab what does the file look like?

Via kodi shares, media settings

Selecting nfs server it shows 3 shares, but can press on okay, but he won’t select that folder

Gave already (ip vero) access to that nfs share, with default settings

On the Vero, ssh in. What does

showmount -e


Export list for

Did you look at the Kodi log to see what errors you may be getting? You can share your kodi log with

grab-logs -X

and paste the url here.

Log removed

Couldnt find log to customize it so it’s big and to much info i guess

Find it :thinking:

The first thing I see is:

20:17:06.069 T:3850994432   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://USERNAME:PASSWORD@'
                                        unix_err:'d' error : 'Permission denied'

You might want to remove that smb share if you are not using it.


20:17:39.013 T:3850994432   ERROR: NFS: Failed to mount nfs share: /volume1/movies (mount/mnt call failed with "RPC error: Mount failed with error MNT3ERR_ACCES(13) Permission denied(13)")

Check the permission settings on the NAS. I assume that you are using the OSMC user to connect? Remember that it’s UID=1000 so make sure that 1000 has access to the share.

I can’t add user in vero for nfs

Do you mean to add osmc user in nas?

Is osmc doing nfs mounts different then coreelec?

I just looked closer, and noticed that you are exporting:


but trying to access:


movies is not exported, volume1 is not exported.

Then you get:

20:17:39.391 T:3850994432   ERROR: Failed to open(//) opendir call failed with "NFS: READDIRPLUS of / failed with NFS3ERR_ACCES(-13)"
20:17:39.392 T:3850994432   ERROR: GetDirectory - Error getting nfs://

That error may be simply file permissions on the NAS.

Can you show what /etc/exports looks like on the NAS?


I’m trying to access 4k dir

With NFS, mapping UIDs does not work well. It’s always best to use the same UIDs when possible. If that’s not possible, then just set file permissions so everyone has read (or rx on directories) . If you need finer control then facls is your friend.

CFor some reason it worked before.

Therefor only change was media player.

So i looked at permissions on 4k folder on volume1


Changed it with chmod 777 to


And i could select it

thankyou @bmillham for helping me out here !!!

That would definitely be a problem! I wonder why it changed!?

No problem, that’s what we are here for.

Yes i’m not sure why it changed, cause i could enter it etc.

Great, now i can continue.