4K content no longer works Vero4K+

I’ve always been able to play 4K movies/shows and now suddenly it doesn’t work. When I try to play something 4K I get no video and the audio is very intermittent/glitchy.

I can play 1080p content or less it seems (I didn’t do extensive testing but I watched a couple of things). I think HDR was working too (I have Arcane in 1080p with HDR and that was working). I don’t know if it’s something with the resolution specifically.

I didn’t change anything in Kodi or any hardware/connections on the Vero. I did change some picture setting on my TV (Sony X90J) but I wouldn’t know what the setting were before to switch them back exactly. They weren’t factory defaults though I did try using a Standard picture setting (reset to factory defaults) but that didn’t help.

Now I did update to the October version (was on the March one before) to see if it would help but it didn’t.

This likely doesn’t mean anything but I was able to get it working for about 15 seconds once by immediately hitting OK on the remote twice (like how you normally pause playback) after selecting the file. I guess I managed to pause it the instant it loaded. While paused, the video suddenly appeared and when I unpaused it ran for about 15 seconds before the problem kicked in again. But every other time the remote didn’t do anything and I have to shut off the TV to get back to the file system within Kodi.

I did get a log of me trying to play Avengers Endgame and then having to shut down the TV (not sure how that affects Kodi/the log):

I found another topic talking about Overscan and I tried playing with the X90J’s settings (Full Pixel was the mode to use I believe it was called) but it didn’t help. I tried rebooting, shutting down, unplugging the power entirely to the Vero and all peripherals. I have a powered USB hub and two powered HDDs connected to it with my content. But like I said this isn’t a new setup, it was working fine before.

So I’m stuck now, I’ve been able to fix other problems I’ve had but this one I can’t figure out unfortunately.

Does changing ‘Adjust display refreshrate’ to ‘Always’ help?

No but I was just making an installation drive when I saw your reply. It’s probably easier if I attempt a reinstall. I don’t use Kodi’s functions, I just navigate to my files manually so there’s nothing in terms of settings or library for me to preserve.

Reinstall didn’t work but I went through the TV video settings for a while and I had changed the HDMI3/eARC signal format from Standard to Enhanced as per X90J guides on improving video quality. So the fix was simply to change it back to Standard.

I didn’t consider some of these things might affect how the Vero or the AVR passes/processes the signal. Obviously changing the Gamma or Brightness or TrueMotion wouldn’t affect it but I checked all the settings I thought could reasonably affect the signal and it turned out it was a TV setting in the end.

Is your Vero directly connected to the TV or is an AVR in between? If there’s an AVR can you check if it works if you directly connect the Vero to the TV?

And second test: can you try a different HDMI port on your TV?

Glad to hear this is now solved.