4K content yields black screen and no audio today?

Took today’s update and just finished watching some of my 1080p content and then tried to watch some 4K content and nothing plays. Have tried 5 different things that I normally can play and nothing works. Not sure where to start?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Log file here…


Come to think of it, this issue probably cropped up at least last week. I remember now that I tried some 4k content last weekend and had an error and just thought it was a one-off.

In that log file is a 4K movie that I had started watching a couple of weeks ago and now I can’t watch it. So I know a few weeks ago that file did play without problem and now it doesn’t.

It always help to give the name of the movie so that the team can find it faster in the logs, I assume it is The.Suicide.Squad.2021.mkv

Also what is the purpose of your whitelisting? I would remove it as your current one doesn’t make sense and would just give problems.

Yes that is the one for the log, but anything 4k doesn’t play now. The Whitelisting is probably just legacy settings. I can strip that out now?

Well, I tried removing all the whitelists and that had no effect. However, if I change “Adjust display refresh rate” to off, my 4k content will play, but it only outputs in 1920x1080. I had it set to ‘Always’ and that never caused problems and everything worked just dandy. I tried ‘On start/stop’ and I still get nothing.

I’m really stumped why this has become an issue. I have had my Vero 4k+ for several years and it’s been quite awhile since I dumped the config and reconfigured from scratch. I’d rather not have to go through that exercise now, but do I have some kind of stale/corrupted setting? I’m suspicious that is the case. I haven’t changed anything in AVR (STR-DN1080) or my TV so I’m stumped why this issue has popped up all of a sudden?

Have you tried using a different HDMI cable?

Does it work if you take the AVR out of the chain?

I’ll try just to make sure.

However, it was working 2 weeks ago with all the same cables and gear and no changes since then. The Vero → AVR cable is the one that shipped with the Vero and has always been reliable.

I also have an AppleTV 4k going into the AVR and it has no problem passing 4k HDR content through the AVR to the Samsung TV, which means the AVR->TV cable should be just fine and the AVR doesn’t seem to have an issue outputing/passing through 4k HDR content.

Actually, my fallback is to use MrMC on AppleTV 4K and I just used that tonight since I can’t get the Vero to cooperate. So feel pretty good that AVR and HDMI cables are not the problem unless the Vero HDMI->AVR cable is now faulty for some reason

Yeah, I’m not very confident about that, but cables can fail sometimes, for purely mechanical reasons, and an HDMI signal problem would fit the symptoms.

I’m even less hopeful about this helping, but have you tried forcing 4:2:2 colour sub-sampling?

Son of a gun. It looks like the HDMI cable that came with the Vero and goes from Vero 4k->AVR might have been the issue after all. I’ve swapped around some of the cables and it’s playing the 4k content again.

However, I’m getting some HDMI reliability issues now where it seems that the HDMI signal is having a hard time locking in (e.g. I’ll see the KODI GUI, but it will have a noisy and pink color cast, but restarting everything seems resolve it).

How in the world an HDMI cable that was working fine for 2+ years that hasn’t been touched, moved or otherwise altered can just stop working for 4k is amazing to me. Is this really a thing? I’m just not used to seeing a cable ‘wear out’ in this respect.

I presume that now that HDMI 2.1 cables are pretty common, replacing all my HDMI with 2.1 standard cables should be an improvement, right?

I’ve had that happen before. Sometimes the weight of the cable pulling on the plug can eventually cause wear or strain in either the plug or the socket. Could conceivably be a corrosion problem too, if it’s a cheap cable.

The picture quality will be exactly the same as you would get from a non-faulty 18gbps cable, but if you think you might eventually use the same cable with an HDMI 2.1 device, go for it.

Replaced all cables with new 8k HDMI 2.1 cables and all seems to be just fine and back to normal now. I chose to use 2.1 cables even though they are not required. My assumption is that decent quality 8K 2.1 HDMI cables should be adequately over-specced to meet the needs of 4K resolution and refresh rates.

I’m still quite surprised that a cable that worked fine 2 weeks ago failed. There’s no visible corrosion, bending or wear and tear on the cable. Reseating the cables had no impact either. Just have to chalk this up to another case of how important cable integrity / quality is for 4k signals.