4k Display setting not saving

For some reason my Vero 4k always reverts to 1080p. I don’t know if its restarting when I am not using it or what but every time I set it to 4k then the next day its back on 1080p without fail.

It seems to function fine at 4k 60hz so not sure why it would have to revert to 1080p all the time.

Any ideas?

That the setting is not saved is a bit strange and something we should check separately.

But generally we recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty)
Settings>Player>Videos>Adjust display refresh rate> On start/stop

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Ok. Are you sure that 4k content is played in 4k when display is set to 1080p because the quality seems a lot better when the interface is set to 4k, maybe that is just my eyes thinking it looks better.

I will leave it on 1080p and see how it goes, thanks.

It will! Did you configured
Settings>Player>Videos>Adjust display refresh rate> On start/stop

i’ll have to check when I get home this evening. I don’t think I have that enabled because I was trying to prevent it from changing.

Ok, that would explain. Set 1080p and enable it and the Vero4k will switch automatically to 4k when you play 4k content.

With some make/models of TV, a GUI setting of 4k will be ‘forgotten’ if the TV is turned off (even if just in standby).

If you could elaborate on exactly the behavior you were looking to get (other than a 4k GUI) then we may be able to suggest other settings that are suitable for your application.

I think the OP’s goal is to have his GUI at the same resolution as the videos he’s playing so he doesn’t get a 1-2 second black-out as the video starts and finishes. But he needs to be aware:

  • when playing any video which isn’t at the same resolution and refreshrate as the GUI Vero will have to scale that video so the risk of un-smooth playback increases.
  • Vero will likely fall back to 1080p GUI setting when the TV is off (especially if there’s an AVR in between)

Is that a TV issue then rather than a vero 4k problem? I used to connect my desktop PC over HDMI and had to unplug the cable every time and that used to default to 1080p every time as well. So maybe it is just the way the HDMI works? I have a samsung ks7000

What is the issue with setting 4k, in terms of vero not being ready for that?

You can see when you go to the AVR information detail for video that when playing the video it doesn’t automatically change to 4k. If you are playing 4k content at 1080p that is not making full use of the 4k content.

I will continue to manually change the resolution to 4k when I play 4k content.

The recommended setup is GUI at 1080p and Adjust refresh rate (in Settings->Player) at On start/stop or Always. You should not have to manually change resolution.

There’s just no advantage in setting the GUI to 4k because it’s not designed for it (all the images etc are designed for 1080p).

Why would you manually change? If you do what was suggested: Set the GUI to 1080 and Adjust Refresh Rate to Start/Stop then you will have videos playing in 4K. If that does not work, post logs so we can see what’s happening.

If you think playing at 1080p and set the refresh rate to match the video is the solution then I am not sure you know what you are talking about.

I want to play at 4k, I want the stream on the AVR to say 4k and if it doesn’t then it is not playing in 4k, simple as that.

It works fine at 4k 60hz with hdmi 2 so not sure why I would want to play at 1080p and lower refresh rate. Maybe you can explain why that is better?

You need to take a chill pill. Setting the GUI to 1080p and Adjust Refresh Rate to Start/Stop will send a 4K signal to the AVR if it’s a 4K source. That’s the idea of Adjust Refresh Rate.

If you continue to act this way, it’s about time to lock this thread as you apparently have no intent on actually trying the setup we’ve suggested, and if it’s not working you clearly are not willing to supply logs so we can figure out why what it working for everyone else is not working for you.

OK I am sorry. I just couldn’t understand why a lower refresh rate would be preferred.

I set you suggested setting and it does in fact change the resolution to 4k and set the refresh rate to match the video. It works well, i will leave it on that now as i don’t have to adjust the display settings all the time.