4K extremely unstable after the latest update

Dear Community,

I don’t know what else to do with my Vero 4K. I’ve been on the version 20171102 since almost the beginning, as updating to a newer one would cause extreme instability.

I mainly use this box with the IPTV plugin (simple IPTV) and for streaming movies and series from my NAS over my internal network. Sometimes I also use the Plex plugin and Youtube.

As for skins, I use the default Kodi one, i.e. nothing fancy.

I have never been able to update without running into a :frowning: face after the new version loads up and I start scrolling the menus.

I’ve even tried to install a fresh version, from USB (that’s how I was able to downgrade to the only stable version that I’ve known), however I don’t want to be stuck in the 2017 version for ever.

I would greatly appreciate any help with this issue as my wife now hates the box all together. It’s frustrating if you can’t watch an episode of game of thrones, without it freezing completely and requiring a quick unplug from the electricity in order to reboot.


I’m sorry to hear this.
You shouldn’t need to use such an old version of OSMC.

Can you confirm which version you tried with a fresh install?

The 2018.10 image has some video improvements that may be hit and miss but should generally work well.

Lastly, do you have any posts or references regarding this issue in the past. This could be helpful.

We will certainly be able to resolve this for you


Dear @sam_nazarko,

First of all I would like to thank you for your reply and for looking into my issues. The last version I’ve tried to install from scratch was probably the April version. After that I just went back to the 20171102 and that solved the reboots and freezing.

I did not try any fresh install from there? Initially I also thought that the IPTV simple plugin could be causing this, as it has not been updated in a very long time. However now when using my NAS and trying to watch something (no 4k, just normal (x264), 1080p to 720p files), my box freezes at least once.

I have not tried to reinstall the most recent version from scratch, as it behaves similarly to the April version. The other thing that I find strange is that I have not been able to update this box without a crash at the end of the update. It does update, however I always get a :frowning: face at the end of the process.

As for logs, I unfortunately don’t know how to generate them. If you could point me to a tutorial I would gladly like to provide you with more information in the hope of finding the root cause of the issues.

I wish you and the community a pleasant weekend.



PS: I have two of the boxes (one was a present for my father) and I got the same behaviour on both of them.


Details for logs can found here:

How to submit a useful support request - General - OSMC

This is known issue, I believe its down to a skin helper issue. All though I believe it has been fixed in later versions of osmc. it used to be quite common: update, sadface and then kodi starts as normal and no further issues in most cases.

Thanks Tom.

Yes, that is indeed a harmless message but should be gone when v18 is finalised