4k files stutter when played from NAS

OK here is the log : https://drive.google.com/file/d/1r11yRrfHwBSN8Lv15cbS4M1YSoNwi3FI/view?usp=sharing

I justed attempted to play a simple 4k/hdr file. Same problem with other files such as 4k demos. At the beginning quiet scene, but some lags already. At the end action scene, sounds stop, slideshow => unwatchable.

File is stored on a local NAS which delivers high bandwiths (limited by gigabit network).
Hope you have sufficient data, don’t hesitate to ask for more.

What’s the mediainfo of the file?
Are you mounting nfs via fstab?
Please use OSMC to upload logs

Ok I uploaded via osmc. I’ll test later eith usb drive to see if it’s network related

What’s the URL?


I just tried with usb drive and I can confirm it’s smooth, so I conclude it’s network related. I use smb and it wasn’t workng at the beginning. I had to edit smb.conf file and put
client min protocol = SMB1
instead of
client min protocol = SMB2

maybe there is something there, I’ll look into

OK I adjusted my NAS cofniguration and retored original smb.conf, but problem still there

Are you mounting via fstab or you use the Kodi samba client?

I don’t know what fstab is, so I guess I use Kodi samba client

First add the cache setting I suggested in this post

Second suggest to switch to fstab mounts that are explained here

I just tried cache settings : amazing it works ! No more lags. Thanks !

I’m interested in switching to fstab, just one questions : what about the path stored in MySQL database ? I have to ensure they remains the same because the database is shared with other kodi devices - not on OSMC

For that cases path substitution was invented.

Thanks for pointing this, it’s good to know there is a solution. That’s a lot of things to do, and as long as it works I’ll try avoid doing this.
In my understanding those workarounds are needed because of Vero 4K network limited to 100Mbps. Do you know if USB to ethernet device like this one works in OSMC ? This would improve bandwidth a lot.

I would more say it is needed because of the unperforming userspace samba support in Kodi.

If that specific one is working I can not say but if you look through the forum you will see people who are using usb gigabit adapters. Generally everything that has a Linux driver should be able to get going but might require manual work.

I experienced stutter and lag when playing 4k movies from my NAS. :roll_eyes:
Now everything’s fine.
Here is how I solved that, thanks to older posts on this forum, I hope this will help you and solve your issue

In the configuration menu, player / videos :
Adjust refresh rate : on start
Sync playback to display : no

In the menu system/display :
Resolution : 1920x1080p (osmc will automatically switch to 4k if the movie is 4k)
Refresh rate : 60.00 (It’ll adjust automatically thanks to the “adjust refresh rate” option

After that, create the advancedsettings.xml file :
To create this file you have to connect to the VERO 4k with putty (or any other ssh tool)
If you don’t know the IP address of your VERO : Programs / OSMC / Network icon

Then identify as OSMC with the default id/pass:
User : osmc
Password : osmc

Then enter the following command :

nano .kodi/userdata/advancedsettings.xml

That will open the nano editor
Then type the following lines :


Then press Ctrl+X to quit and Y to save the file

Now reboot the VERO and try to read au 4k movie on your NAS :slight_smile:

You can play around with the values in the advancedsettings file.
My example works great for me (VERO 4k + NAS, NFS share, multiple boxes running osmc, shared media library…)

If think SAM should add an option in order to have correct advancedsettings.xml in OSMC “out of the box”, something like “activate advancedsettings.xml for playback over ethernet”…

Thanks for the hints cyrliv. In between I received my USB to ethernet device, just plugged it and it worked like a charm. I confirms it helps a lot.

I have to test with larger file to ensure everything is fine now. In case of problems I’ll consider switching from SMB to NFS, as it seems NFS has better performances.

At home I have the vero 4k connected to the network with its original ethernet interface (100 mbps) : I don’t use any usb to gigabit adapter.
The vero, via ethernet 100 mbps, plays all my movies played without any problem. Even the 80Go++ h265 HDR DTS MA movies !!

OK it’s good to know. The fact is you’re using NFS and that’s why you don’t have same problems as me. SMB is slower by design and suffers poor implementation in Kodi.

NFS is supported by my NAS so I could migrate, but it would by time consuming because I would have to migrate all my path in MySQL database, or to use path substitution as proposed by fzinken.

It’s hard for me to spend time on this so that’s why I give the USB gigabit adapter a try first. If its not satisfying I’ll migrate in NFS and write a script to migrate paths. Time will tell, I’ll give feedback to you.