[4k+] [NFS] Extreme slow library update

Hi there,

Received the 4K+ yesterday.
Mounted my Movies en TV-Shows folder from my server with autofs (should be faster than build-in method).

The Vero can find my server and does start indexing.

However… Opening the NFS from the file browser is extremely slow (waiting 5 min before something shows) and lets the system hang every now and then.

Also the indexing for the library is extremely slow.
My TV shows took about 7 hours (2 TB of shows in 720p)
And the movies stopped (again) with tmdb not responding.
But when it did work, it managed to get 5 movies in 6 or 7 hours.

Should I use FTP instead of NFS?
Is it normal that it is so slow?

Have a windows machine with kodi and use the same NFS shares. Here it loads the complete tv show library in 10 min.

Are you using wired or wireless network?

Wired, full-duplex 1Gbit.
Same cable, same switch and so as on the windows machine.

Check your upload and download speed with iperf3

using no special arguments ( with and without -R) gives me somewere around 200kbit… so thats not good…

(firewall disabled)
Running with -u -b 1000M -R gives me 500Mbit, without the -R 15Mbit.
Did a restart, same results…

Same kable, port, etc., plugged in my PC gives me 900Mbit

200kbit (not MBit) in both directions? That’s something new we haven’t seen before. Your UDP readings are more like it.
Have you tried different cable and port?

Indeed those speeds are terrible.
As told before… plugged the cable 20cm away in my htpc and that does 900Mbit. So cable and switch cant be the problem.

eththool eth0 gives me

Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
Transceiver: external
Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
Current message level: 0x0000003d (61)
drv link timer ifdown ifup
Link detected: yes

curl -s https://raw.githubusercontent.com/sivel/speedtest-cli/master/speedtest.py | python -

gives me 5,97 Mbit down and 0,95Mbit up… my link is 750Mbit up and down…
Looks like something is seriously wrong with the LAN.

To give some more info about the network…

ISP = T-Mobile fiber with 750Mbit up and down
Router = Ubiquiti Unifi Security Gateway Pro
Switch = Ubiquiti Unifi Switch 24
Cables are all CAT.7 SFTP terminated to a 24P Patchpannel CAT.6A and in-wall CAT.6A on the other side.
Patch-cables are all CAT.7

Server is a Windows Server 2012R2
Problems are only to/from the Vero 4K+
HTPC, Xbox-One X, TV, NAS, Mobile, PC and so all get 1Gbit (between 920Mbit and 1.02Gbit)

Have seen issues with that switch before. Assume @sam_nazarko needs to take a look at this

Can you try with a different switch / cable?

Will try soon.
Just configured the wifi, that works OK.

Should it be OK to just put another switch between the Vero and the unifi switch?
Getting the unifi switch out of the equation is nearly impossible.

Ps. I know how to handle ssh and do also have console access to the unifi switch.
If you need me to try something to find the problem, let me know.

Can you try another switch to test?

Reconnected the Vero to the LAN cable of my receiver (so all cables are different now).
The route was Vero -> Patchpannel -> USW24 -> Server.
Now it is Vero -> Patchpannel -> 10 port tp-link switch -> Patchpannel -> USW24 -> Server

Still getting around 350Kbit (Yes K, not M).
So other cables and adding an different switch in between did not do anything.

This evening I will try to make it Vero -> Patchpannel -> 24 port Zyxel GS1900 E24 -> Server
The USW24 will then be connected to the Zyxel so the network is complete. But no traffic over the USW24 for Vero to Server data.

@sam_nazarko, Some tests I can do for you to find out what the problem is?
Eventually the Vero has to have 1Gbit data while connected to the USW24.

Please contact support@osmc.tv with a link to this thread so we can replace the device.


You think it is faulty hardware?
I am capable of doing some SSH commands if needed.

Have a little Linux experience and work as PLC programmer and Network and ICT Manager.

It depends. If you have tested it in another environment then possibly

As you can see I have tested it on an other switch with other cables.
Still the same problem.

looks like I am having the same error:

Reverse mode, remote host server1 is sending
[ 4] local port 56068 connected to port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 77.8 MBytes 652 Mbits/sec
server1 receiving
[ 4] local port 56070 connected to port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 181 KBytes 1.48 Mbits/sec 23 2.83 KBytes

Switch is Netgear GS724Tv3 (FW
Same results when putting a GS105 v4 beetwen the Vero 4k+ and the GS724Tv3

Did you fix the problem yet @Wvanelten @sam_nazarko?

Did you try a different cable?
Otherwise you may need to return it