4K+ out of box failure :( :( :(

just got my 4K+, very excite!

Powered on. Get an small OSMC logo, a bit of linux stuff, LED goes red then LED goes out then linux text (white text on black background) then the sad face, all in a matter of seconds. It never boots into Kodi or anything; just sad face.

I’ve tried repowering a few times, repowered minus RF remote USB thing and even without HDMI / ETH to no avail.

Nothing works. Lots of sad face. Seems to be trying to replace sad face as occasionally sad face screen flickers then I see some linux text then another sad face. Repeats over and over every few seconds.

Do I need to reimage or reset or do I have a dud?

Cheers, Geoff.

Yes, I suggest a reinstall first. Also ensure that you have the Vero4k directly connected to the wall power outlet.

Sounds like power issue.
If reimage doesn’t resolve issue, then I’d try emailing sales@osmc.tv for replacement psu

thx. Worked. All good now. 4K+ seems very snappy.

thx; re-image did the trick. Thanks for suggestion.

1 Like

great !!!
enjoy Vero 4K + :slight_smile:

Did you power it and move it to a different TV? This might have corrupted the initial install.

It should be fine now

1 Like