4K resolutions appearing twice in whitelist

4K 50, 59.94 and 60Hz resolutions appear twice in my my whitelist options. Is there a good reason for that?

Logs: https://paste.osmc.tv/bekakopojo

There’s a reason, but it’s not a good one.

It’s because Amlogic list 4k 420 modes separately from other 4k modes. It should not affect things in practice but needs tidying up.

If it were possible to whitelist 420 modes but not 422, that might actually be useful. As things stand, if you select one of the two modes but not the other, the next time you go back in, they’re both selected.

That will not happen. We will only use 422 if forced with the setting or if 420 isn’t supported at 4k (which is pretty unlikely).

I guess I’m still hoping I might find a combination of settings that gives me 422 at lower resolutions and 420 for 4K50 and 4K60. :slight_smile: You have to pick one or the other at the moment…

If you have a way with your fancy gear to send a custom EDID, set MaxTMDSclock to 450, then we won’t send 422 at 60Hz.

1 Like