4k+ RF Remote not functioning, and help with IR universal remote setup

First the included OSMC RF remote for the Vero stopped functioning. I performed the typical troubleshooting steps of replacing the batteries and attempting the re-pair the remote.

Upon holding home+ok for 5 seconds, the blue light in the remote comes on but does not blink. Upon inserting the dongle into the box, the blue light stays on for a while and then disappears. It never blinks during this pairing procedure, so what is happening?

I have done this procedure after rebooting and powering off the Vero box several times.

I have also tried to do this procedure on a Windows computer. The dongle is recognized upon insertion, however none of the remote buttons do anything.

This is also the second time this issue has happened. The first time a new remote was ordered. I performed all of the same steps above on both of the remotes and both behave the same in regards to trying to pair with the dongle.

Why won’t either remote go into pairing mode?

logs: https://paste.osmc.tv/ufagokopin

Now I would also have a universal IR remote I’d like to setup, but I had trouble using “irrecord”. Where exactly is the IR receiver on the Vero 4k+ box? Using irrecord it checks for ambient light, and then asks to hold down a button on the remote. Trying this several times with several different buttons results in the same outcome: The procedure timeouts, not recognizing anything.

If it is a universal remote why not just program it for one of the preconfigured remotes in the My OSMC add-on (such as an Xbox or MCE) and avoid the trouble of trying to get a working custom profile?

The dongle is being recognised by OSMC, which is good.

Is it possible you’ve mixed up the dongles between the remotes?


There is only one dongle and I’ve tried both remotes with it.

It’s concerning that the IR is not being recognized. Where is the built-in IR receiver located, physically, on the box?

The receiver is located on the front behind the “+” cutout. I would guess the issue with making your own profile is just finding the correct instructions. This isn’t something I’ve done myself but I know there are some services that have to be stopped before recording. But again, if you just select a remote profile in My OSMC and program your universal remote to what you has selected that should get you what you want.

1 Like

What makes you think the built in receiver is not being recognised?
We should be able to check via some logs if it’s being detected

We can resolve the OSMC remote issue if you contact support@osmc.tv with your order details.


It would timeout when I was trying to manually program it using “irrecord” command.

However, I found a workable solution by using one of the configs for the WDTV remote, and luckily the universal remote had a code for Western Digital. The remote is a Terk 6 device (revision 26211) for those interested. It’s not a perfect solution as the volume keys don’t function and I don’t think there is an analog to the “options” hamburger key of the included OSMC remote, but those aren’t necessary functions for day to day use.

Thanks for the help everyone.

What your calling “options” I’m assuming is the context menu kodi action. You can install the keymap editor add-on and use that to map this action to whatever key you want (use global). As for the volume you can do the same thing and it will work if you have a sound bar or AVR with CEC but in your case there is probably an option for your remote that will make the volume buttons send commands only to the device of your choice regardless of which device you are currently controlling and that would be the better option.