4k video playback issue after October update


#1

Hi,

I have a Vero 4K (media connected via a USB disk), a Samsung UE65KS8000 (EU model name, in the US it’s called UN65KS9000) TV and a Denon AVR-X3300W AVR. Connection: Vero > AVR > TV

Before the October update I could play back everything almost just fine. The one issue I had was the well known banding issue. I enabled the auto HDR switch in the menu but that didn’t worked for me Vero just crashed when I tried to play a 4k file. So I turned it off and installed this “ebuhuyajej” hotfix. Sadly the hotfix did nothing for me, banding still remained, but at least I was able to play back everything but ofc only in 8 bit with banding.

AFTER I installed the October update the AVR OSD finally says 10 bit but and the playback starts but stops after a few sec later and I get no audio and no video then i comes back for a few sec later and goes black and mute after a few sec again. So now it makes all my 4k files completely unwatchable… (1080p and SD works fine)

Can someone help me?

From the TV’s manual:

When you connect the TV to the external device that supports only UHD 24 or 30 Hz frequency or any FHD frequency, the HDMI UHD Color function may not be available. In this case, set HDMI UHD Color to Off.
The HDMI connector with HDMI UHD Color set to Off supports up to UHD 50P/60P 4:2:0 input signals, while the HDMI connector with HDMI UHD Color set to On supports up to UHD 50P/60P 4:4:4 and 4:2:2 input signals.


#2

Do you know how to use SSH? If not – I can prepare a hotfix for you.
We need to get rid of the original hotfix applied to your system.


#4

i used putty but it was several years ago so if you can send me a step by step guide most likely i will be able to do it also THX a lot in advance!


#5

See https://osmc.tv/wiki/general/accessing-the-command-line/

You want to remove one line from /etc/rc.local


#6

Hi, I was able to SSH on my device. So how exactly do I delete that line?


#7

sudo nano /etc/rc.local


#8

seems like there’s nothing in this file to be removed:
image


#9

Then you need to provide debug enabled logs demonstrating your issue so that we can figure out what might be going on.


#10

Ok, hopefully I did it right. Here’s the log> http://paste.osmc.tv/asahekemor
I enabled debug logging and then i tried to play two 4K HDR file that played “well” before October uptade. With “well” I mean the output was only 8bit hence with banding but at least they played back, now most of the time I see black screen and no audio and then for a few sec I get picture + audio, then black again, furthermore I noticed several tiny white dots on the screen during I got image and audio.


#11

Hi, so anyone has a clue what’s wrong?


#12

Hi,

We are working on some video improvements which we will make available shortly.

Sam


#13

Hi Sam, thx for the feedback!


#14

Hi Sam, any update you could share with me?


#15

Hi

Hopefully the issue is now addressed

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


#16

Should I remove the “deb http://apt.osmc.tv stretch main” line that’s already in the sources.list file?
or how does the apt-get knows which source to use?


#17

No, do not remove anything that you were not advised to.


#18

and does it matter where I add the line? before or after the line I just mentioned?


#19

should be the last line in sources.list


#20

it asked me "After this operation, 243 MB of additional disk space will be used.
Do you want to continue? [Y/n] ", I sad yes.


#21

That is correct, and don’t forget after the update completes to remove the line you added so sources.list (so you don’t get updates that you don’t want)