4k video playback via the receiver stops

Hi guys,

I got a Vero4k+ as a replacement for my RPi where I was running OSMC as it was about time to jump into the 4k world. After installing everything, updating the Vero and restoring a backup to get my settings, I tested that everything that worked before was still working, mainly IPTV and 1080p x264 local video files. All good!

My Vero4k is connected to a Samsung KS7080 via a Pioneer VSX-324 all the way via HDMI. The GUI resolution is set to 1080p@60 and “adjust display refresh rate” is set to always in Player Settings. The manufacturer claims 4k compatibility for that receiver.

However, when I play the following samples, video playback starts but the TV goes black after a few seconds and the sound is quickly lost after, too. After a few seconds the playback resumes but it fails again after a while. Nothing is written to kodi.log (see below) when this happens and the receiver does not show anything odd on the screen.

The same happens with a x265 Bluray rip.

What’s troubling is that when I connect my Vero4k+ directly to the TV using either of the two cables (one of them is the one that came with the Vero, the other one is an Amazon basics one) everything works fine. I thought about connecting the Vero directly to the TV and do audio pass-though all the way down to the receiver but my TV does not support that unfortunately. Another option would be to connect the Vero to the receiver using an optical audio cable, I guess.

I don’t know what else to do to debug this issue and I’m about to give up and forget about getting the signal through my receiver :(. Does anybody happen to have any other idea?

Thanks for reading!

21:52:40.150 T:4080751184  NOTICE: VideoPlayer: Opening: /mnt/somewhere/data/Demos/Samsung_Wonderland_Demo.ts
21:52:40.150 T:4080751184 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
21:52:40.151 T:3362779904  NOTICE: Creating InputStream
21:52:40.187 T:3362779904  NOTICE: Creating Demuxer
21:52:41.066 T:3362779904  NOTICE: Opening stream: 0 source: 256
21:52:41.066 T:3362779904  NOTICE: Creating video codec with codec id: 174
21:52:41.066 T:3362779904   ERROR: CBitstreamConverter::Open hvcC data too small or missing
21:52:41.067 T:3362779904   ERROR: Unable to load libamplayer.so, reason: libamplayer.so: cannot open shared object file: No such file or directory
21:52:41.068 T:3362779904 WARNING: CAMLCodec::CAMLCodec libamplayer.so not found, trying libamcodec.so instead
21:52:41.073 T:3362779904  NOTICE: Creating video thread
21:52:41.074 T:3362779904  NOTICE: Opening stream: 1 source: 256
21:52:41.074 T:3362779904  NOTICE: Finding audio codec for: 86018
21:52:41.075 T:3404788480  NOTICE: running thread: video_thread
21:52:41.075 T:3362779904  NOTICE: Creating audio thread
21:52:41.076 T:3396399872  NOTICE: running thread: CVideoPlayerAudio::Process()
21:52:41.293 T:3362779904  NOTICE: Opening stream: 0 source: 256
21:52:41.294 T:3362779904  NOTICE: Creating video codec with codec id: 174
21:52:41.295 T:3362779904   ERROR: Unable to load libamplayer.so, reason: libamplayer.so: cannot open shared object file: No such file or directory
21:52:41.295 T:3362779904 WARNING: CAMLCodec::CAMLCodec libamplayer.so not found, trying libamcodec.so instead
21:52:41.295 T:3362779904  NOTICE: Opening stream: 1 source: 256
21:52:41.502 T:3396399872  NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 48000, no pass-through)
21:52:41.599 T:3404788480  NOTICE: CAMLCodec::OpenDecoder - using V4L2 pts format: 64Bit
21:52:41.850 T:4080751184  NOTICE: Display resolution ADJUST : 3840x2160 @ 23.98 - Full Screen (33) (weight: 0.000)
21:52:42.049 T:4080751184  NOTICE: VideoPlayer: OnLostDisplay received
21:52:42.365 T:3404788480 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
21:52:42.380 T:4080751184   ERROR: EGL error in CreateSurface: 3003
21:52:42.380 T:4080751184  NOTICE: CreateWindow: Could not create a surface. Trying with a fresh Native Window.
21:52:42.381 T:4080751184  NOTICE: VideoPlayer: OnResetDisplay received

Hi

Unfortunately it’s difficult to see what’s going on here without a complete log.

Sam

Look around in the settings in your Pioneer and make sure that the HDMI is set to handle 4K. Also look for other 4K settings. Like on my Yamaha there a setting called 4K that changes how it handles 50/60Hz color.

Hi Sam,

Thanks for answering.

Guess you mean a debug level log of the playback? I’m attaching the full log since I selected the video on the UI to be played until it finishes.

Nothing is logged specifically when the screen goes black, the only event that correlates to anything I see on the screen is:

DEBUG: CEGLNativeTypeAmlogic: Detected HDMI switch

which is printed when the TV shows a “No signal” error message.

Hi,

Thanks for the suggestion. I went through all the menus of the receiver and I couldn’t find anything specific to 4k video :frowning:

I’ve found this though on the manual which is alarming, is it not?

4K signal transfer

–This may not operate properly, depending on the connected equipment.
– 4K 24p, 4K 25p and 4K 30p signals are supported.

Could it be that the playback is eventually going over those 30p?

If the problem only occurs if the AVR is between the Vero and the TV but a direct HDMI connection works flawlessly between the OSMC device and the TV, it’s obvious that the AVR introduces the issue.
We can offer to look again into a log set but this time follow our steps to collect it:

You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Hi,

Yes, it’s kind of obvious as I mentioned but I was hoping that there was something that could be configured on the OSMC side to make the AVR happy. You have to understand that I’d rather not to spend money on extra equipment if I can avoid it :slight_smile:

I’m sorry if my report was not good enough. I tried to explain the best I could my hardware and software setup, the issue I was facing and the investigations I had carried out so far myself with my limited technical skills and jargon :blush:

Sure, I thought the full debug log of the playback that reproduces the issue that’s already attached above would be enough. I will do this later once I’m at home.

I was looking over the product manual and it has some interesting language regarding HDMI pass through.

Important information regarding the HDMI connection

There are cases where you may not be able to route HDMI signals through this receiver (this depends on the HDMI equipped component you are connecting-check with the manufacturer for HDMI compatibility information).

If you aren’t receiving HDMI signals properly through this receiver (from your component), please try the following configuration when connecting up.

Configuration

Connect your HDMI-equipped component directly to the display using an HDMI cable. Then use the most convenient connection (digital is recommended) for sending audio to the receiver. See the operating instructions for more on audio connections. Set the display volume to minimum when using this configuration.

How long is your Amazon Basics cable?
If it’s 3ft then the issue is definitely your AVR in my opinion.
If your Amazon Basics cable is 6ft or longer try to find a 3ft cable and test that out.
Otherwise it looks like you might just have to go straight to the TV.
Your TV has optical out and HDMI ARC but doesn’t do pass through?
Not even DD 5.1?
Hopefully you find some setting on your AVR that your just overlooking.
I looked over the entire manual and saw nothing other than language that made it sound like they weren’t that confident in their devices own abilities to pass through 4K even though it’s marketed as being able to.

Hi Kontratian,

First of all, thank you very much for your time.

My Amazon Basics cable is 2m (around 6.5ft long). It does work fine when connecting the Vero directly to the TV but it could be that when used to connect the AVR to the TV it creates issues when there are 4k video streams over the wire. I can try to find a shorter cable to rule this out :slight_smile:

My TV is a bit stupid, I think. In terms of audio I can play with two options:

  • HDMI Audio Format sets the format of the audio input signal so that it is suitable for the external device connected to one of the TV’s HDMI ports.
  • Audio Format selects the digital audio output (S/PDIF) format. The available formats depend on the input source.al device connected to one of the TV’s HDMI ports.

In my case the possible values for the former option are PCM and bitstream (I guess bitstream is the correct one if audio pass-through is enabled in Kodi), however for the latter I can only select PCM or DTS Neo 2:5. There’s no way I can ask the telly to send the raw audio stream untouched down to the AVR. Rubbish!

I think the best option if I don’t sort this out is to connect the Vero directly to the TV, then connect the Vero and the AVR via a TOSLINK cable and finally disable audio over HDMI on the Kodi settings.

This is Pioneer’s reply to my inquiry:

Thank you for your email. This sounds like it may be an issues with the HDCP versions. You receiver, manufactured in 2013, has an older version of HDCP. With many newer devices, the newer version of HDCP is supported, version 2.2. The versions are not backwards compatible at the older versions have become compromised and are susceptible to copyright infringement.

Please check the HDCP version of all devices from sources to the TV, you will find this detail in the user manual of each product under the HDMI specification section. If they do not match the HDCP 1.4 of the amp then I believe this will be the cause of the problem. In that case, it would be necessary to use a workaround. You could try connecting the source directly to the TV by HDMI and then also connecting an optical cable from the TV or source back to the receiver for the sound. That way, the older HDCP device is bypassed so picture can reach the TV and sound is transferred by a non HDCP supported means.

:frowning: That’s indeed the workaround I had in mind however they forgot to mention that connecting the Vero to the AVR via S/PDIF means no HD sound pass-through as far as I understand :frowning:

And in case it was useful for other Samsung users, this is their reply regarding the pass-through via HDMI:

Le téléviseur joue le rôle d’une passerelle entre les deux équipements, il n’est pas possible de désactiver le traitement de son au niveau de ce dernier.

Je regrette de ne pas pouvoir vous offrir une autre solution.

Free translation:

The TV plays the role of a bridge between the two devices. It’s not possible to disable the processing of the sound.

We’re sorry we cannot offer any other solution

This is what I’ve done at the end in case it was useful for somebody landing here in the future.

  • Connect the Vero4k+ directly to the display via HDMI.
  • Connect the Vero4k+ to the AVR using a TOSLINK cable.
  • Mute HDMI audio output (display settings) on the Vero4k+.
  • Enable DD and DTS pass-though.
  • Enable AC3 transcoding (see guide).

What are you referring to here? If it’s the output device (HDMI or PCM), this does not matter - both are doing the same. If it’s referring to DTS-HD and TrueHD, then those two have to be disabled for TOSLINK output, but they’re not called HDMI audio.

Just to prevent any confusion. :wink:

System settings -> Display -> Mute HDMI audio output. I’ve clarified my previous post.

1 Like