4tb samsung 870 QVO not working with osmc


i got my first osmc up and working, nearly everything is fine. now i wanted to add 4tb ssd with usb-adapter, but unfortunately osmc is not recognizing the ssd (only the adapter). the ssd is definitly not defective, as it is working with win10 and i was able to build a ext4-partition with raspberry pi os (64bit) on same raspberry pi 4.

does anybody has any clue why this is not working?

It could be a power problem. Are you using a power hub?
First step is upload logs grab-logs -J-K


when i put an old hdd in this adapter, osmc regognized it. i think the ssd will take much less power, and also raspberry pi os had no problem with same setup…

I see one device recognised as 250GB. Is that a different SSD?

yes it is. 250gb for system and downloads, 4tb for all the stuff…

Run lsblk -f and share the output

Also ls -lah /media/

osmc@osmc:~$ lsblk -f
NAME        FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
`-sda1      ext4         ff7c4411-8c5f-43ed-b5ff-cebeacb38d78  200.8G     7% /
`-mmcblk0p1 vfat         AE53-64B5                             255.6M    19% /boot

osmc@osmc:~$ ls -lah /media/
total 12K
drwxr-xr-x  2 root root 4.0K Feb 10 18:53 .
drwxr-xr-x 20 root root 4.0K Feb 10 20:08 ..
-rw-r--r--  1 root root  232 Jul  2  2020 README

run sudo e2label /dev/sda1 sdd_disk (for sdd_disk) you can use any name you like and reboot. You then should see it at /media/sdd_disk

the command had no error, but i do not see it at /media/sdd_disk

it would also be the wrong ssd, i need sdb as it is the second ssd in this system

Well all that seems not be detected as lsblk shows. I suggest you connect it pi os and then run lsblk -f to check what partitions and filesystem are done.

Actually looking at the output above again. Could it be that you install OSMC onto the SDD? It looks like that! That for sure would overwrite the filesystems.

osmc was installed on 250gb ssd without 4tb ssd attached.

the problem is that this 4tb ssd is not detected by osmc, while it will be detcted from win10 or pi os. so my question is - why?:wink:

btw - trying to install osmc on this 4tb ssd also failed with an error. could there be a problem with the debian and only a newer version like pi os is able to detect this ssd?

Ok, so it is a second SDD in a second USB enclosure?
What is the manufacturer of the enclosure? Is it a USB3 device?

Maybe boot PiOS again and share the dmesg output as a comparison.

Also is it possible to swap the enclosure of the 250gb and 4tb disk to see if the issue might be with the enclosure and not the disk?

it is a second ssd in a second enclosure. swapping is not possible as the 250gb ssd is an m.2-disc, 4tb ssd is 2,5" sata.

both are using usb3. i also thought it might be the enclosure, but this is working with piOS. i also tried 2 other enclosures i have (with different IDs, all with same result)

As mentioned next step is dmesg from piOS

interesting: booting piOS with both ssds the 4tb ssd is also not responding. booting it only with the 4tb ssd everything is fine.

also: booting only with sd card - plugging in 4tb ok
booting only with sd card - plugging in 256gb ssd - ok, plugging in 4tb ssd - not responding…


with 256gb ssd AND normal hdd no problem…ok, but right now i think i have a lot to try, if i fiind something or need help i will ask again. thanks so much for trying right now.

i try to install osmc on 4tb ssd without anything attached, 3A original power adapter: install failed, can’t mount root.

the solution in the end: i installed osmc on another ssd without problems, copy this partition to the 4tb ssd - it works…for some reason it is not possible to install osmc or pi os directly.