5.1 Audio Problem - no passthrough?


#1

Hello

I am having issues getting 5.1 audio to work properly. It seems the only way I can reliably get the centre channel and the back channels to work is to have the output set to 2.0 with transcoding enabled.

When I disable sync to display and then set the audio to 5.1 and Best match it seems to not map the centre channel and it seems to not want to pass through sound. My receiver can play DTS and pretty much all the formats which should be passed through but I never see it reporting DTS as having been detected.

The following is a extract from the logs for a file which has 5.1 (AAC I think) and only wants to output stereo front left and and front right, the centre channel is completely missing.

12:03:04.351 T:4081500752 NOTICE: VideoPlayer: Opening: http://XXXXX.mkv
12:03:04.351 T:4081500752 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
12:03:04.352 T:3178418944 NOTICE: Creating InputStream
12:03:04.673 T:3178418944 NOTICE: Creating Demuxer
12:03:05.302 T:3178418944 NOTICE: Opening stream: 0 source: 256
12:03:05.302 T:3178418944 NOTICE: Creating video codec with codec id: 174
12:03:05.303 T:3178418944 ERROR: Unable to load libamplayer.so, reason: libamplayer.so: cannot open shared object file: No such file or directory
12:03:05.303 T:3178418944 WARNING: CAMLCodec::CAMLCodec libamplayer.so not found, trying libamcodec.so instead
12:03:05.304 T:3178418944 NOTICE: Creating video thread
12:03:05.304 T:3178418944 NOTICE: Opening stream: 1 source: 256
12:03:05.304 T:3195163392 NOTICE: running thread: video_thread
12:03:05.304 T:3178418944 NOTICE: Finding audio codec for: 86018
12:03:05.308 T:3178418944 NOTICE: Creating audio thread
12:03:05.308 T:3841192704 NOTICE: running thread: CVideoPlayerAudio::Process()
12:03:05.308 T:3178418944 NOTICE: Opening stream: 3 source: 256
12:03:05.323 T:3841192704 NOTICE: Creating audio stream (codec id: 86018, channels: 6, sample rate: 48000, no pass-through)
12:03:05.533 T:3195163392 NOTICE: CAMLCodec::OpenDecoder - using V4L2 pts format: 64Bit
12:03:05.791 T:4081500752 NOTICE: Display resolution ADJUST : 1920x1080 @ 23.98 - Full Screen (28) (weight: 0.000)
12:03:05.983 T:4081500752 NOTICE: VideoPlayer: OnLostDisplay received
12:03:06.270 T:4081500752 NOTICE: VideoPlayer: OnResetDisplay received
12:03:06.287 T:3195163392 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
12:03:23.330 T:4081500752 NOTICE: CVideoPlayer::CloseFile()
12:03:23.330 T:4081500752 NOTICE: VideoPlayer: waiting for threads to exit
12:03:23.338 T:3178418944 NOTICE: CVideoPlayer::OnExit()
12:03:23.338 T:3178418944 NOTICE: Closing stream player 1
12:03:23.338 T:3178418944 NOTICE: Waiting for audio thread to exit
12:03:23.350 T:3841192704 NOTICE: thread end: CVideoPlayerAudio::OnExit()
12:03:23.350 T:3178418944 NOTICE: Closing audio device
12:03:23.395 T:3178418944 NOTICE: Deleting audio codec
12:03:23.396 T:3178418944 NOTICE: Closing stream player 2
12:03:23.396 T:3178418944 NOTICE: waiting for video thread to exit
12:03:23.404 T:3195163392 NOTICE: thread end: video_thread
12:03:23.405 T:3178418944 NOTICE: deleting video codec
12:03:23.452 T:3178418944 NOTICE: Closing stream player 3
12:03:23.468 T:4081500752 NOTICE: VideoPlayer: finished waiting
12:03:23.934 T:4081500752 NOTICE: CVideoPlayer::CloseFile()
12:03:23.934 T:4081500752 NOTICE: VideoPlayer: waiting for threads to exit
12:03:23.934 T:4081500752 NOTICE: VideoPlayer: finished waiting
12:03:23.934 T:4081500752 NOTICE: CVideoPlayer::CloseFile()
12:03:23.934 T:4081500752 NOTICE: VideoPlayer: waiting for threads to exit
12:03:23.935 T:4081500752 NOTICE: VideoPlayer: finished waiting

I was previously using the Pi3 connected to this receiver and have now just started using the Vero4k. It is connected through my 4k tv which is setup to output bitstream. Previously the Pi3 worked fine so im thinking its a vero problem. Also when I use the optical and set the input to be CD on my reciever (ie force it to use the optical) with DTS and 5.1 I get no sound at all:

12:14:10.271 T:3223319296 NOTICE: Creating audio stream (codec id: 86061, channels: 8, sample rate: 48000, pass-through)

=> No Sound

with stereo stuff its fine, with 5.1 AAC I get only front right and left channels:

12:45:12.188 T:3132093184 NOTICE: Creating audio stream (codec id: 86018, channels: 6, sample rate: 48000, no pass-through)

I had thought the TV may be the problem but when using the optical only I still get the problem. In fact when I play something with a fully working audio track (eg DTS) via the optical, the gui sounds are fully working then as soon as the video starts the optical signal is no longer detected by the receiver, which is just weird.
I think this may be an EDID issue with my reciever/Vero 4k? Any help would be appreciated.


#2

FYI: cat /sys/class/amhdmitx/amhdmitx0/aud_cap

PCM, 2 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
PCM, 8 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz, bit
DTS, 7 ch, 44.1/48 kHz, bit
OneBitAudio, 6 ch, 44.1 kHz, bit
Dobly_Digital+, 8 ch, 44.1/48 kHz, bit
DTS-HD, 8 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16 bit
MAT, 8 ch, 32/44.1/48/88.2/96/176.4/192 kHz, bit

And:

cat /sys/class/amhdmitx/amhdmitx0/rawedid

00ffffffffffff00412f00000101010100170103808048780adaffa3584aa22917494b2008003140614001010101010101010101010108e80030f2705a80b0588a00ba882100001e023a801871382d40582c4500ba882100001e000000fc004854502d3037322f3037330a20000000fd00173d0f883c000a20202020202001a002034ff157901f05142021220413031207165d5e5f6263646160666538097f070f7f071507503e06c04d02005706005f7f01677f00834f00006e030c001100b83c2f088001020304e305ff01e2004b023a801871382d40582c450010090000001e023a80d072382d40102c458010090000001e000000000000000000000000f5

I can also report than when I set it to 5.1 Fixed, I get no centre channel when I try a file with DTS, for example.


#3

You should connect vero to your receiver and the TV to the receiver HDMI-out. Let us know if that works. If not, we can give you some more pointers.


#4

Ok trying that it appears to work fine for a 1080p file with DTS (except it keeps wanting to switch inputs) but for 4k stuff I get no picture when adjust display refresh rate is enabled.

If I disable that it doesnt auto switch to 4k but the sound is now working.

But I want to use my vero 4k plugged into my TV as I want full 4k, why cant it just pass through the audio untouched without any messing around?


#5

It’s annoying that. If you turn off all your devices and turn them on again, the TV will re-learn where vero is.

So your receiver doesn’t support 4k? What’s the make/model?

Are you saying your TV has HDMI-out? If not, you won’t get the full range of audio formats passed through. Again make/model would help us. Edit: I assume it’s your TX50DX700B, so you have spdif out. Not sure what formats that will pass through but I can check on my similar Panny if that would help.

If you do turn everything off and on again, you may find that video issue clears. If not, please turn on debugging and grab full logs for us.
https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/


#6

Hello

The TV does have HDMI out (well it has ARC, if thats what you mean) but it doesnt seem to work properly when vero is connected directly to the TV. It has optical out but this also doesnt seem to work properly when I try it because as soon as a video starts playing the “optical” indicator on the reciever display starts flashing (when it was playing gui audio perfectly seconds before).

Receiver = Pioneer VSX324
TV = Panasonic TX50DX700B

So I can use the Vero 4k connected to the reciever but only if I do not set the display rate to change automatically (which I want for 4k content).

If its plugged into the tv no combination of settings I can try appears to get the optical audio to work (which I would have thought should have been just as simple as plugging in the optical to the vero and the reciever and just switching to optical input)
Neither directly from the vero or plugging it into the panasonic TV.

Seriously how do you make the vero 4k just output optical audio?


#7

here is a full debugging log for when it is connected directly to the receiver.

Works fine for 1080p but at 4k with display rate changing it gives a black screen and the receiver cannot auto detect the signal type and it keeps cycling through the different connections and not working for any of them.

https://pastebin.com/Kz8XeVcS

So I can either have fully working 4 k content, as long as I am happy for it to transcode the audio, or full 5.1 sound, but without 3160p/24Hz HDR auto switching.
Currently id prefer transcoded sound because I can hear the surround channels and I know they do work, whereas without auto display rate changing the TV is telling me 4k content is coming though at 1080p, which is unacceptable.

But why cant I just have video out HDMI and audio out Optical?


#8

Like you, I’ve struggled to get ARC to work when playing into one of the HDMI inputs on the TV.

I just did some tests here. Optical from vero to AVR (Yamaha 373) works as expected but only on one of the AV inputs for some reason. Optical from TV to AVR kinda works. It’s fine with stereo and 5.1 DTS and DD which is all that can be expected of it.

Connecting vero directly to the receiver is your best bet. Otherwise, you will not get 5.1 sound when playing formats other than DTS and DD.

It looks from that log as if you have enabled the HD passthrough formats. You will never get those through an optical connection. Turn those off and turn on AC3 transcoding. If you still have problems, please post full logs using MyOSMC or grab-logs -A from the commandline.


#9

The issue with transcoding is that there appears to be a variable amount of delay based on the transcoded format and I cant be having to manually adjust and readjust the audio sync with every file I play.


#10

Just looking at your receiver specs, it looks like you are in the same boat as me. The receiver will pass through 4k at 30 (HDMI1.4) but not at 60Hz. If I set my gui to 4k@30Hz then any 4k material will play at 4k and the audio works through HDMI all as advertised. Can you confirm that works, at least?

Then I’ll try some other ways round to see if I can get things working with vero connected direct to TV.

Then you will have to live without surround sound through S/PDIF when the audio tracks are not DD or DTS.

If I ever got into watching 4k60Hz material I would be looking for a new AVR or a HDMI splitter.


#11

Then whats the point of the vero optical out if it cant acutally pass through any audio types???

No unfortunately none of the 4k resolution options would work without the screen occasionally going black.


#12

It passes through stereo PCM and DD and DTS 5.1. That’s all you will ever get out of S/PDIF. Kodi adds the option to encode PCM into DD (AC3) so you can enjoy multi-channel from other formats as well, but it won’t be ‘audiophile’ of course.

I’m wondering if you have cable issues. If you connect vero to the TV using each of the cables in turn, can you play 4k@60Hz?


#13

I dont think its specifically a cable issue as when I try switching the resolutions using a different cable I get the same results and the receiver keeps switching from the HDMI to Analogue like it cant recognize the signal properly.

So if I use the Vero plugged into the reciever, set to 1080p without auto switching (because it doesnt appear to work with the receiver) what would happen with HDR video?


#14

It plays at 1080p.

We can’t help you with that without full logs.


#15

Ok some logs:

https://paste.osmc.tv/ukewupiqup

https://paste.osmc.tv/muloravexa

With and without passthrough enabled. With the optical out enabled I only seem, to get front left and right.

The same cables worked fine for 4k when its hooked directly to the tv and was set to stereo. Its when its anything but 2.0 that I seem to have issues.

I have also been trying it with an hdmi audio splitter I have. With the vero directly into the audio splitter and with the optical out from the splitter into the receiver i am only getting front left and right audio.


#16

Thanks for that. It’s a bit difficult to see what’s going on because you didn’t turn on debug logging in Settings->System->Logging (you may need to change settings level, bottom left, to see it).

Also difficult to spend much time on it as you have a number of banned addons installed. https://kodi.wiki/view/Official:Forum_rules/Banned_add-ons Please remove them if you want more help with this.

Meanwhile, we have just published some guidance on audio connections and setups. It’s a bit complicated but may help you understand what you can achieve and what your options are. Start here: Connecting up your equipment