5GHz Dongle from Store. Connection Failed after Password entry on Raspberry Pi 1

Hi,

the 5GHz Dongle from the shop arrived today and I’m trying to connect to my 5Ghz wifi network and it is failing after the Password entry in the guy and also form command line.

I made sure that the dongle works from windows 10 and can connect to my 5GHz network just fine.

In OSMC, I can see my 2,4 GHz and 5 Ghz wifi just fine. But if I try to connect to either of them, I get connection failed after I have enetered the password.

I’m on a Raspberry Pi 1 and intsalled the 7.2017 image via official installer to a 16GB sd card.

My Edimax 2GHz dongle works just fine in the setup.

I followed the other posts regarding wifi issues and couldn’T solve the issue.

I have tryed different wifi encyrptions settings up to no encryption at all. I double checked that I’m enetring the password correct and also that my router allows new devices.

Anyone knows what the problem is?

SOLUTION: Disable Background scanning.

Have you got WPS enabled?
You might want to turn that off – it’s a security risk anyway.

Sam

I disabled wps.

The system is highly instable freezing regularly and mouse not working randomly.

I set a lower resolution now, but the lagging remains if the dongle is connected.
It is tough to test much without beeing able to change any settings.

Are you sure your power supply is up to the task?

Yes it is powered by an Iphone charger. I’ve been using it for years now. The lagging starts with the 5ghz dongle attached. The edimax 2ghz dongle does not cause any lags.

An IPhone Charger is clearly not the right powersupply for a Pi.

You could try to disable background scanning by making the following change to /etc/connman.conf.

Add the following line under [General],
BackgroundScanning = false

And reboot

The 5Ghz dongle will use a fair bit more power than some of the cheaper 2.4Ghz nano dongles.
An iPhone charger isn’t suitable for a Raspberry Pi and sooner or later you will experience problems.

You can learn more on our Wiki here: https://osmc.tv/wiki/raspberry-pi/frequently-asked-questions/

Ok I got a stronger Powersupply now and the lagging is gone. I still get Connection failed though.

All Nearby Wifis are listed, but after password entry i get connection failed.

And now I cant log into ssh:

I get error:

18:03:05.114 Server version: SSH-2.0-OpenSSH_6.7p1 Raspbian-5+deb8u3
18:03:05.114 First key exchange started.
18:03:05.137 The SSH2 session has terminated with error. Reason: FlowSocketReader: Error receiving bytes. Windows error 10054: An existing connection was forcibly closed by the remote host.

You might have an old version of SSH (i.e. Putty) on your system which doesn’t accept the new key algorithms.

I could connect to it before.

I realised that my router shows the osmc device as connected if i disable any encryption, eventough the webui shows that the connection failed. There is no data exchange though. If I have encryption enebale, even my router wouldnt list the device as connected,

After several tryies and updating to 8.2017 image, i can connect to 2,4 ghz, but trying to connect to 5ghz still delivers a “connection failed”.

Anything more i can do?

I’ve uploaded the full logs:

https://paste.osmc.tv/tusojozuka

the ssh access error is really annoying. I cant do anything on the system now.

Please help!

Sep 28 19:02:02 osmc sshd[460]: error: key_load_public: invalid format
Sep 28 19:02:02 osmc sshd[460]: error: Could not load host key: /etc/ssh/ssh_host_ed25519_key
Sep 28 19:02:02 osmc sshd[460]: fatal: No supported key exchange algorithms [preauth]
Sep 28 19:02:03 osmc sshd[462]: error: key_load_public: invalid format
Sep 28 19:02:03 osmc sshd[462]: error: Could not load host key: /etc/ssh/ssh_host_rsa_key
Sep 28 19:02:03 osmc sshd[462]: error: key_load_public: invalid format
Sep 28 19:02:03 osmc sshd[462]: error: Could not load host key: /etc/ssh/ssh_host_ecdsa_key
Sep 28 19:02:03 osmc sshd[462]: error: key_load_public: invalid format
Sep 28 19:02:03 osmc sshd[462]: error: Could not load host key: /etc/ssh/ssh_host_ed25519_key

Strange. That could suggest some corruption (which can occur if you use an underpowered PSU).

Re. 5Ghz issue: I assume you have separate networks for 5Ghz and 2.4Ghz (ideal). What channel is the 5Ghz on? You might find better luck using 36; and you might need to tweak the connection settings slightly.

First, I’d get SSH fixed though. Try:

sudo -s
RSA_KEY="/etc/ssh/ssh_host_rsa_key"
ECDSA_KEY="/etc/ssh/ssh_host_ecdsa_key"
ED25519_KEY="/etc/ssh/ssh_host_ed25519_key"
ssh-keygen -f $RSA_KEY -N '' -t rsa 
ssh-keygen -f $ECDSA_KEY -N '' -t ecdsa
ssh-keygen -f $ED25519_KEY -N '' -t ed25519

How can issue these commands if I dont have ssh access to the system?

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

OK I went back to build 2016.8 ,which I had been running without any issues for a year know. In that build, the wifi only recognizes 5GHz networks, and also tells me connection failed after I enter the password.

Funny thing I tried channel 36 and I could connect successfully on 5ghz Network. On my 2016.8 build without any tweaks.

What is the problem?

2016.08 is very old. There have been some improvements to the driver since then.

Probably was in wrong CRDA. If 36 works, stick with it for now.

Sam

Yes the build is old, but it is working for me so I try not to change it. Everytime I try to update something, I end up wasting hours to get my system back up and running. SO I rarely update. I installed the latets build, thinking it would be better working out of the box with the new dongle and it would be good to take the opportunity to update it. It did cost me some hours of troublehoosting now.

I didn’t select channel 36 couse there are already some networks using that channel. Getting the 5ghz dongle was actually to avoid all those crowded channels. I will tryout other channels and hope to find one that is empty.

BTW: On windows 10, i also had to switch the region settings in the driver settings to be able to connect to my 5ghz network. Initally it wouldn’t allow me to connect either.

Are there similiar settings I can tweak to allow also higher channels?

What is CRDA btw?

Yes. See OSMC wireless dongle faulty? - #6 by sam_nazarko