5GHz Dongle from Store. Connection Failed after Password entry on Raspberry Pi 1

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

OK I went back to build 2016.8 ,which I had been running without any issues for a year know. In that build, the wifi only recognizes 5GHz networks, and also tells me connection failed after I enter the password.

Funny thing I tried channel 36 and I could connect successfully on 5ghz Network. On my 2016.8 build without any tweaks.

What is the problem?

2016.08 is very old. There have been some improvements to the driver since then.

Probably was in wrong CRDA. If 36 works, stick with it for now.

Sam

Yes the build is old, but it is working for me so I try not to change it. Everytime I try to update something, I end up wasting hours to get my system back up and running. SO I rarely update. I installed the latets build, thinking it would be better working out of the box with the new dongle and it would be good to take the opportunity to update it. It did cost me some hours of troublehoosting now.

I didn’t select channel 36 couse there are already some networks using that channel. Getting the 5ghz dongle was actually to avoid all those crowded channels. I will tryout other channels and hope to find one that is empty.

BTW: On windows 10, i also had to switch the region settings in the driver settings to be able to connect to my 5ghz network. Initally it wouldn’t allow me to connect either.

Are there similiar settings I can tweak to allow also higher channels?

What is CRDA btw?

Yes. See OSMC wireless dongle faulty? - #6 by sam_nazarko

I have still issues with the dongle. Although the dongle now connects fine to my 5Ghz network and I also have more than 120 Mbits of connection speed, I have noted that If I stream a high definition file over the network or Stream my desktop via moonlight, after 2-3 minutes the raspberry willl loose wifi connection. And it will take some 4-5 minutes for the raspberry to reconnect to my wifi.

The OSMC will not crash or reboot. Just the wifi connection will drop and will be dropped for 4-5 minutes.
On my 2.5 Ghz wifi dongle, I could stream on moonlight for hours without interruption if I the wifi managed to get a decent wifi connection of at least 2-3 Mbits.

Also if the 2.5 Ghz wifi would drop connection, it would reconnect in matter of seconds rather than minutes.

As recommended, I also got a stronger Power Supply of at least 2.5 Amps.

Has this issue been observed before? What could be the problem?

Check My OSMC -> Network when this happens.
Does it show you as connected?

If you unplug / replug the router (if you’re able to); does OSMC find and reconnect to the network quickly? Really the connection shouldn’t be dropping at all on 2.4Ghz or 5Ghz dongles.

My raspberry is headless and I normally control it via wifi remote app.

I will connect mose and check the settings. But I suspect that the settings will also show the connection as disconnected. My router shows no connection when this happens. If everything is working my router shows normally a good conenction of 120 Mbits to the raspberry.

If I pull the plug on the raspberry and it restarts, the connection is made instantly like it should.

I can reproduce this by putting load on the wifi. 99% of the time I use osmc and the raspberry to stream my desktop via moonlight and play the media on my desktop. That apparently puts a heavy load on the wifi dongle and it looks like it crashes.

If I play some youtube video that uses low bandwith or let the raspberry idel, the connection remains stable. i can see in my routers history that there are nromally no disconnects from the osmc rapsberry.

OK Here is the relevant section of the log:

Oct 14 03:05:00 osmc kernel: 80211> CFG80211_OpsScan ==>
Oct 14 03:05:01 osmc kernel: 80211> Can not find any chan info!
Oct 14 03:05:01 osmc kernel: 80211> Can not find any chan info!
Oct 14 03:05:01 osmc kernel: 80211> Can not find any chan info!
Oct 14 03:05:01 osmc kernel: 80211> Can not find any chan info!

A full log is easier to read and would be handy.

The current log doesn’t show any issue.

Sam

Here ist the full log:

and anotherone:

This is from the 7.2017 version of osmc.

Hi @Rocket

IIRC: 2017.07 had a problem with background scanning; which would explain why networks are slow to reconnect sometimes.

The first thing I’d recommend doing is updating OSMC.

Yeah I did that. I’m currently on 9.2017. And the issue now somewhat changed.

After a connection drop, a reconnect happens much quicker within seconds now.
I monitored the network speed and nvidiastream uploads with peak speeds of 200-300 KB/s. if I stream a complex video. Normally it remains at 80-90 KB/s. If I stream a full hd 3d movie, The rates go up to 2-3 MB/s. These speeds schould be easy to handle for the 5ghz dongle.

I think the issue is with moonlight.

This is the verbose output:

Moonlight Embedded 2.4.3 (EMBEDDED;ALSA;PI)
Connect to 192.168.178.100…
NVIDIA GeForce GTX 960, GFE 3.1.2.31 (gs_03_40_21369817, 7.1.340.0)
Platform Raspberry Pi (Broadcom)
Loading mappingfile /usr/share/moonlight/gamecontrollerdb.txt
Stream 1280 x 720, 60 fps, 10000 kbps
Initializing platform…done
Resolving host name…done
Starting RTSP handshake…done
Initializing control stream…done
Initializing video stream…done
Initializing audio stream…done
Initializing input stream…done
Starting control stream…done
Starting video stream…done
Starting audio stream…done
Starting input stream…done
Returning RTP packet queued for too long
Received OOS audio data (expected 35171, but got 35172)
Control stream connection failed
Loss Stats: Transaction failed: 101
Stopping input stream…done
Stopping audio stream…Video Ping: send() failed: 101
done
Stopping video stream…done
Stopping control stream…done
Cleaning up input stream…done
Cleaning up audio stream…done
Cleaning up video stream…done
Cleaning up control stream…done
Cleaning up platform…done

A new Geforce Experience Version was released just now. I will test it with the new one.

But to be honest I had bad experience with updateing GFE. Moonlight was borken on every update.

Unfortunately I’m not a Moonlight expert. I am struggling to get it to work on Vero 4K (but working on it).

If you have another Linux system, preferably Wired, then check out iperf. That will let you know if you’re getting the speeds you should be getting

Sam

I have to correct myself. It is not an Moonlight issue.

It is definitely an issue with the 5GHz dongle.

I tested with my old 2,5 Ghzs Micro USB dongle and with 24 Mbit available speed, Moonlight streams flawlessly without interruptions.

Maybe even 2,5 AMps PSU is still not enough.

WIll a USB hb with an seperate powersupply do? If I connect the Wifi dongle to that selfpowered hub?

I’ll try to find an powerd hub.

I can’t believe 2,5 AMps is not enough with just the WIfi dongle attached to the raspberry.

Strange that the 2,5 Ghz dongle works flawlessly.

This sounds very strange.

Did you try disabling background scanning?

Is the issue now reconnection time, or throughput?

Sam

I have already updated to the latest version of OSMC. I’m on 9.2017.

Do I have to manually disable background scanning?

How/where can I modify the dongle’s settings?

You mentioned this Post: OSMC wireless dongle faulty? - #6 by sam_nazarko

But there is no /lib/firmware/mt7610u_sta.dat on my device just: mt7610u_sta.template.dat.

Shall I rename it and change settings?

What settings shall I change?

#The word of “Default” must not be removed
Default
CountryRegion=31
CountryRegionABand=7
CountryCode=
ChannelGeography=1
SSID=11n-AP
NetworkType=Infra
WirelessMode=8
EfuseBufferMode=0
Channel=0
BeaconPeriod=100
TxPower=100
BGProtection=0
TxPreamble=0
RTSThreshold=2347
FragThreshold=2346
TxBurst=1
PktAggregate=0
WmmCapable=0
AckPolicy=0;0;0;0
AuthMode=OPEN
EncrypType=NONE
WPAPSK=
DefaultKeyID=1
Key1Type=0
Key1Str=
Key2Type=0
Key2Str=
Key3Type=0
Key3Str=
Key4Type=0
Key4Str=
PSMode=CAM
AutoRoaming=0
RoamThreshold=70
APSDCapable=0
APSDAC=0;0;0;0
HT_RDG=1
HT_EXTCHA=0
HT_OpMode=0
HT_MpduDensity=4
HT_BW=1
HT_BADecline=0
HT_AutoBA=1
HT_AMSDU=0
HT_BAWinSize=64
HT_GI=1
HT_MCS=33
HT_MIMOPSMode=3
HT_DisallowTKIP=1
HT_STBC=0
VHT_BW=1
VHT_SGI=1
VHT_STBC=0
EthConvertMode=
EthCloneMac=
IEEE80211H=0
TGnWifiTest=0
WirelessEvent=0
MeshId=MESH
MeshAutoLink=1
MeshAuthMode=OPEN
MeshEncrypType=NONE
MeshWPAKEY=
MeshDefaultkey=1
MeshWEPKEY=
CarrierDetect=0
AntDiversity=0
BeaconLostTime=4
FtSupport=0
Wapiifname=ra0
WapiPsk=
WapiPskType=
WapiUserCertPath=
WapiAsCertPath=
PSP_XLINK_MODE=0
WscManufacturer=
WscModelName=
WscDeviceName=
WscModelNumber=
WscSerialNumber=
RadioOn=1
WIDIEnable=1
P2P_L2SD_SCAN_TOGGLE=3
Wsc4digitPinCode=0
P2P_WIDIEnable=0
PMFMFPC=0
PMFMFPR=0
PMFSHA256=0

Yes, check this

Yes there was no: BackgroundScanning = false

in /etc/connman.conf .

I added that line. Lets see if that helps.

You think I’m having power issues? Does the osmc dongle work without a Usb hub attached directly to the rpi?

I’mean 2,5 amps just for the rpi and dongle schould be more than enough right?