8188eu problems on latest version

I have a TP-LINK TP-725N v2 (chipset 8188eu) which worked fine till today(last friday was fine).

I’m having a lot of connection dropouts after a few time or some links.
Connection starts failing and Internet is then reported down on system info, but I still got an IP and I can still ssh to the RPI2.
After a short while shh also goes down and network is off.

On the previous version everything worked fine except for one thing. The dongle disconnected if the RPI2 was left untouched for a bunch of hours(8+). I’m guessing it was going into standby mode and never coming back till a reset.

I know the drivers for these dongles suck but has anything changed lately?

What logs should I post to help out?


yes, it’s known that 8188eu drivers are not that good… you can find evidence of that in the forum.
I have the same dongle you own, and by now my solution is: use another dongle :smile:
Developers said that they know the problem and that they will recompile “good drivers” in the future (i hope near future), but atm there’s not much you can’t do (afaik)
if you think about that, even for raspbian someone is compiling manually the 8188eu drivers since the embedded ones are rubbish…

When I said “had something changed lately” I meant for the worst…

What I meant was that the previous version (altought not perfect) worked alot better that this latest version.

I the new “driver”(don’t know if it’s the driver) is not working well, then we should rollback for now…

There were no wifi driver changes between RC2 and RC3 nor in any updates since RC3.

thanks for the reply mandrake.
I digged a little deeper and the connection seems to be lost a lot!

wlan0 Link encap:Ethernet HWaddr 64:66:b3:1f:4e:c8
inet addr: Bcast: Mask:
inet6 addr: fe80::6666:b3ff:fe1f:4ec8/64 Scope:Link
RX packets:3579 errors:0 dropped:669 overruns:0 frame:0
TX packets:4044 errors:0 dropped:1 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1405015 (1.3 MiB) TX bytes:979607 (956.6 KiB)

but dmesg seems ok:
[ 4.823860] systemd-udevd[124]: starting version 215
[ 5.284734] r8188eu: module is from the staging directory, the quality is unknown, you have been warned.
[ 5.299391] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_A_CUT_1T1R_RomVer(0)
[ 5.335667] usbcore: registered new interface driver r8188eu
[ 5.446513] random: nonblocking pool is initialized
[ 5.506926] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 6.443911] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[ 7.160476] systemd-journald[102]: Received request to flush runtime journal from PID 1
[ 7.303798] smsc95xx 1-1.1:1.0 eth0: hardware isn’t capable of remote wakeup
[ 7.304089] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 8.001884] MAC Address = 64:66:b3:1f:4e:c8
[ 8.005860] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 8.099939] cfg80211: Calling CRDA to update world regulatory domain
[ 12.633017] R8188EU: ERROR assoc success
[ 12.633293] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 13.639847] Console: switching to colour dummy device 80x30

nothing changed on my side… same power supply… always worked.

any sugestions?