96KHz via USB Audio


just installed the April update and checked the settings.

While doing so, I realized that the audio I stream via my USB-Audio (Devialet expert) is downsampled when playing high res audio. 44.1 and 48 kHz is playing correctly. 96khz is downsampled to 48khz.

Is there something I can change? Right now, the sampling is set to “best fit”.

Best regards

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

You will probably have two USB dacs in your audio settings - Make sure you have the dacname,SPDIF selected the dacname,analogue is limited to 48KHz .