A couple of issues

hi, i’m facing two issues at the moment running latest update on rpi 2
issue 1: if tv is on and the rpi starts up CEC works fine, once i switch the tv off and back again CEC controls are gone
issue 2: i’m trying to run transmission but want to save the downloads to my NAS which is a HDD attached to my wifi router.

about issue 1; i already read some forums about it but nothing worked for me
about issue 2; i edited fstab to mount the share folder to /home/osmc/torrents with 777 permissions, yet everytime i start a torrent i get a permission denied (the torrent folder can’t be created)

And your model of TV is ? And is it connect via an AVR ?

sorry, more details:
i have a samsung tv which gets recognized when pi reads the device name, the pi is linked to an hdmi matrix which is hooked to the tv.


yes i read that and did apply but for some reason nothing changes

If by hdmi matrix you mean some sort of HDMI switcher then it is possible you will have trouble with CEC through such a device. There was another thread with the same problem just a couple of days ago.

yes i mean a HDMI switcher, i never had encountered this problem with the one i had before, might swap it back on see if the problem persists. any idea about transmission?

Remove the switch while creating the edid file. After that, put the switch back in place and test for function.

ok my bad just noticed that i had to run the edid write function when the tv is off while the rpi is on. looks like it has been fixed i’ll try again later for a longer time and will let you know

You must run sudo tvservice -d edid.dat while the TV is on and the HDMI switch is removed.

ok got it , thanks man

i have no way to hook the tv directly to RPi, as the tv is wall mounted and the hmdi ports are on the back …

So use the HDMI cable that is now connected between the avr and the TV?

yes i only have one available cable then i’ll have to move a round a lot of things.
so i need plug the RPI directly to the tv dump the edid and move it to boot partition.?

The instructions provided are quite clear, yes.

ok just did that, it worked when it was direcly hooked then when i put the switch back on and swicthed the tv off then on, CEC stopped fucntioning. do i have to reboot the rpi afterwards?
let me explain i have a samsung tv with 4 hdmi ports but only one on the side thats the one that is connected to the output of the lmatrix. The matrix has 4 inputs (Chromecast, PS4, VU+ and the RPI) when i press on source on remote control i see 2 CEC enabed devices (CHromcast and Kodi thats what the TV names them) when i click on Kodi i get no signal, when i choose Chromecast i see Kodi but without CEC support if the rpi was on while the TV is off, when its not CEC works just fine