A specific movie is not playing: timer increases like it's playing normally, but it's a black screen

I have a brand new Pi 3 B+, and the latest OSMC.

I tried a few movies, and they work, but I have an MKV that will not play. It looks like it’s playing, and I can forward/jump, but there is no image, just a black screen. No audio although sometimes when I jump, after buffering it plays a few seconds of audio.

If I play the movie with VLC on my desktop, it’s fine.

Here is the codec info from MediaInfo: https://paste.osmc.tv/ujuvoyusad
Here is Kodi’s debug log: https://paste.osmc.tv/otedewekod

(Note that at the time I saved the kodi log, I was playing it from a fileshare on the LAN, but before I posted this, I transferred it to the SD card and tried playing it from there and it’s the same).

Any ideas? Thanks.

Main 10@L4@Main will not play on the Pi3 smoothly as the Pi3 doesn’t have H265 hardware decoding and CPU is not fast enough.

So it’s normal for the screen to be black? The H265 test video posted on the OSMS wiki plays (although choppy), but my movie has no image at all.

Can you give me a list of codecs to avoid when downloading backups of my movies? Other than h265, what do I avoid?

Instead of downloading backups, you should be using a tool like MakeMKV so you can be assured that you are getting a quality rip!

Hi-10 is exclusive to the anime scene; not supported on any hardware. It can be played by software on high end Intel systems

For reliable HEVC playback, you’ll need a Vero 4K +


Thanks for the info. It’s not an anime, although it is a Japanese movie. Why are the weeaboos so fond of Hi-10 if it won’t play on most HTPCs and mobile devices? Oh well.

Because anime compresses really well if you are encoding it with x264 10 bit

I’d re-encode it with Handbrake to make it play nice on the Pi. (And preserve frame-rate and try pass-through for audio)