AAC 5.1 output as Stereo 2.0

Hi all,

I just noticed that my aac 5.1 files are being output as 2.0 stereo, even though the audio stream registers

Audio stream: ff-aac, FL, FR, LFE, BL, BR, 32 bits, 48,000 Hz.

When I play the same file through my 4k player, it outputs as 5.1 PCM.

Please see attached logs,

https://paste.osmc.tv/junijagopi

Please advise if you need more information.Any help would be much appreciated.

Regards,

Jason.

The first thing I would suggest would be to get rid of all of the banned addons. They are know to cause issues and are filling your logs with lots of messages making it hard to read.

What happens if you try changing the Number of Channels from 7.1 to 2.0?

1 Like

Your equipment is reporting it supports 8 channel PCM so why not leave it set to 7.1 channels and disable AC3 transcoding. I don’t think transcoding would have any positive effect in your application.

Hiya,

Your suggestion fixes the problem. Is this a permanent fix, as in, even though I have a 7.1 setup, I can leave the number of channels at 2.0.

I have had the Vero for 3 years now, so it’s probably time I cleared out the things I don’t use, thanks for the advice.

Many thanks,

Jason.

Hi, it seems that I only get the option to disable AC3 transcoding if I set the number of channels to 2.0. If I select 7.1 channels, this option is no longer available.

Thanks,

Jason.

You would set it to two channels, disable transcoding, then set it back to 7.1 channels output.

It would be good to know if setting it to two channels with transcoding as bmillham suggested produced multichannel output as well.

Bmillham’s suggestion does produce multichannel audio.

I have tried your suggestion, but that still outputs 2.0 stereo for AAC 5.1. If I disable AC3 transcoding, it doesn’t matter if I set speakers to 2.0 or 7.1, AAC 5.1 is output as 2.0. Bmillham’s suggestion seems to be the one that works.

Thanks,

Jason.

1 Like

Whatever the issue is I think it will probably be fixed with the next update. My system is using the staging updates and that file your playing is working on my system output as either multichannel PCM or transcoding to AC3.

(and I was mistaken about the transcode setting. when you set your system to anything other than 2 channels transcoding is disabled.)

1 Like

Can confirm that multichannel AAC is working correct with current OSMC staging. All examples of https://www2.iis.fraunhofer.de/AAC/multichannel.html work here with correct number of channels in PCM with my Vero 4k and output config of 7.1.

1 Like
====================== OSMC Packages =================== 7nQvfy9a
ii  a2dp-app-osmc                        1.1.3                             all          A2DP streaming capabilities for OSMC
...
ii  pulseaudio                           10.0-1+deb9u1                     armhf        PulseAudio sound server
ii  pulseaudio-module-bluetooth          10.0-1+deb9u1                     armhf        Bluetooth module for PulseAudio sound server
ii  pulseaudio-module-zeroconf           10.0-1+deb9u1                     armhf        Zeroconf module for PulseAudio sound server
ii  pulseaudio-utils                     10.0-1+deb9u1                     armhf        Command line tools for the PulseAudio sound server

@Brozzie Do you use Bluetooth audio connections on this system or was it installed just for a test?

Hi Jim,

I havn’t used Bluetooth in a long time with the Vero so it must have been as a test, but I can’t remember from how long ago.

Thanks,

Jason.

May I suggest to get rid of this unused stack and check then whether your problem still exists? I would do

sudo systemctl stop mediacenter
sudo apt remove --purge a2dp-app-osmc pulseaudio pulseaudio-utils libpulse0
sudo apt autoremove
sudo shutdown -r now

to remove all these unneeded packages; answer Y=yes when asked.

Thanks Jim, do I type it exactly like that?

Those are the exact commands. You would put it in one line at a time and press enter after each line as they are four different commands.

1 Like

Thanks Darwin, Will try it in a few minutes.

Hi Jim, ran through the commands and on first test it works. Could you please explain why this was causing an issue?

Many thanks. I’ve posted logs if you want a look…

https://paste.osmc.tv/izaharesaz

Thanks to everybody for their help.

Regards, Jason.

Kudos goes to @grahamh. He saw that PulseAudio is active in your logs and experimental audio Bluetooth stack is the most possible reason for such installation. For a Bluetooth headphone or speaker set the 2 channel solution of this stack makes sense but not in a native environment with a modern AVR/TV via hdmi. Hope all is fine, now.

2 Likes

Yes, thank you very much.