Absense of dialogue track while watching movies with audio stream in 5.1 DTS and Dolby to 3.0 configured reciever. Dialogue track plays via other sources with a 5.1 DTS and Dolby stream. Not sure, but is this a problem with the OSMC Vero 4k+ device?

Everything had been fine for over a year with this setup. I had my entire system disassembled for the first time since successfully putting it together a year prior the other day. Now, when playing movies with 5.1 DTS/Dolby audio streams, dialogue is absent. I plugged my HDD movie source directly into the TV’s usb input and am able to get the dialogue stream from every audio track on any of my .mkv’s while playing through the TV’s (TV itself is capable of playing .mkv’s).

Not sure what could be causing this. 2.0 channel audio tracks play with dialogue, but 5.1 channel audio tracks do not.

Appreciate your help!

Alll devices are plugged via hdmi into a ‘samsung one connect’ cable and toslink cable from the one connect to the audio reciever. So essentially, the OSMC device is outputting audio via HDMI to the TV which is then outputting audio via optical to the receiver.

Please read this post about correctly setting up your audio.

Also to get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

The solution, in my case, was to enable ‘allow audio passthrough’ in the settings.