AC3 passthrough via HDMI doesn't work on TVs?

Hi there,

I’m a new OSMC user on Raspberry Pi 3. So far I was self-sufficient in resolving any minor issues I’ve found, but I’ve encountered one I cannot find a good solution for and the problem might be that I don’t understand all those Home Theater stuff well yet.
It’s about DD/DTS audio from the movies.

Let’s start with my basic setup and some facts:

OSMC @ Pi3
Samsung TV 6 series - supports Dolby Digital, Dolby Digital Plus, DTS(Core, LBR)
Philips HTL5160 soundbar - no DTS support, only DD

OSMC is connected to TV via HDMI1 (STB) and TV with the soundbar via HDMI2 (ARC). No direct connection between OSMC and soundbar.

Everything works well but the DD/DTS passthrough. When I connect a USB drive to the TV with movies with DD/DTS audio it seems to work correctly. For DD my soundbar displays DD on it’s little screen, so it’s sent correctly via HDMI ARC. For DTS it displays PCM which I guess is because the TV knows what the soundbar cannot decode DTS via HDMI so it decodes it itself and streams as PCM. That’s only my guess, can someone confirm that devices can provide such information via HDMI?

When I stream the same videos via DLNA (either OSMC@Pi or a different DLNA server on my PC) it’s still correct and the soundbar displays DD/PCM respectively.

However when I try the same videos played directly on OSMC it suddenly stops working. When I enable passthrough for DD I simply hear nothing at all. I even physically disconnected the soundbar to take it out of the equation and make sure it’s not an issue here.

Interestingly when I connect OSMC to the soundbar directly and then to TV (this soundbar has a HDMI in, so I can put it between the OSMC and TV) the DD sound is decoded correctly, so it’s not the OSMC being the problem, but rather my TV. I would even stay with that setup, but unfortunately it causes other problems I’d like to avoid.

I’ve done a lot of research past few days, spending hours on trying different configurations, reading the internet and I think I found the reason… my TV simply cannot pass through a 5.1 digital input from HDMI. Here is a good article about it: Our TV Input Tests: Audio Passthrough -
My TV is not on the list, but I think it’s from 2014, so probably doesn’t support that.

It’s not a big issue now as my soundbar is just a placeholder for a year or so until I change my apartment to sth bigger. I can live without this feature for a while. I have a full 5.1 sound system stored in my home town and plan to use it one day. My amp supports both DD and DTS, so would be nice to pass the audio intact to it.

How do you guys solve this problem? Does it make sense to buy a TV which simply supports it (not so easy to find it in the specs though) or are there any reasonable workarounds?

Sorry for such a long post, but I’m new to Home Theater independent of my PC and I’d like to learn a lesson here. I’ve spent roughly 2 days writing it and checking some stuff I found meanwhile.

Most TV’s are unable to passthrough multi-channel audio from an external source. You say that connecting directly to the soundbar works as expected. Then why not continue to use this configuration? This is the whole point of the soundbar having this feature.

Well, maybe I bought a wrong soundbar, but let me explain why this configuration sucks for me.

When it’s connected like that I have to have my soundbar remote somewhere close to be able to switch the sources properly. When I’m watching TV the sound goes through HDMI ARC, soundbar detects that and switches itself to HDMI ARC source playing TV sound like it’s supposed to.
However when I switch TV source to OSMC my TV says No Signal, because soundbar has it’s source set to HDMI ARC and OSMC comes from HDMI IN, so I have to grab it’s remote and switch to HDMI IN manually. What’s even more frustrating is that for some reason after I switch soundbar to HDMI IN it automatically switches back to HDMI ARC in a second and I have to switch it to HDMI IN once again before the OSMC screen becomes visible. It’s really annoying that way. When I switch from OSMC to TV it’s good then, however it happens that I lose my Anynet+ (CEC) connection and can no longer use TV remote to set volume on soundbar. Refreshing the connection solves the problem, but it’s quite frustrating and I don’t know if it’s more on the TV side or the soundbar issue.
If I would be the only user I would probably live with that, but my girlfriend is not very good at technical stuff, so I’d like everything to be easy.

When it’s connected the other way around (OSMC -> TV -> soundbar) I don’t have the issue when switching TV source and I don’t have to keep my soundbar remote nearby. I use TV remote to set volume of soundbar which is much easier.
This way I’m still getting the CEC being randomly (?) disconnected when switching TV sources, but it’s less likely.

Can you connect Pi to TV via HDMI and TV to sounbar via optical.

I assume with passthrough disabled in kodi that work correctly?
If you enable DD passthough you get no audio?

Most likely the TV doesn’t support passthrough deliberately (the licensing rules are complicated, but it is quite possible that the TV is allowed to decode DD with its internal player but not passthough from an external player).

Read this and try the hdmi_audio_config=0x200 option. It is a long shot, but it’s worth a try.

Already tried. Nothing changes. Even if I disconnect soundbar completely and use just TV speakers sound doesn’t play.

Exactly. It gets decoded to PCM (at least this is what my soundbar says). What’s interesting is that somehow it seems to handle multichannel quite well then. My soundbar is 3.1, which means it has a center speaker for dialogs. I’ve checked few different videos and dialogs tend to come from the center speaker all the time.

Wow… just did another test. Dialogs play on center even for videos with stereo mp3, so it must be a soundbar’s DSP or something that does that, not the input channels.

I’m using Number of channels = 2.1 setting, cause when I set it to 3.1 (which would match my soundbar’s channels) it gets weird. For most 5.1 movies (DD or DTS) dialogs get totaly silent, sometimes being barely audible. For stereo it does not change anything.

Yes, pure silence.

Probably. What’s the optimal solution to overcome this problem?

Still the same. Yes, I’ve rebooted the Pi after the change.

You must set number of channels to “2.0” when using toslink. It does not support multichannel PCM.

I´ve running into a similar problem months ago… Similar setup, Samsung series 8 + Yamaha soundbar. My tv downmixes to 2.0 all the sound channels coming from any external device connected to the tv inputs, so when outputs the signal over the hdmi to the soundbar, is passing a “poor” stereo channel always.
Best workaround i´ve found in my case was and hdmi switch, because my soundbar can pass both audio and image signals over hdmi output. So I connected all my devices to the switch, then the switch connects to the hdmi input of the soundbar, then the soundbar connects to the tv through hdmi arc…
So, i´m getting the tv sound to the soundbar from arc, and the rest of the sound sources come from the switch, while the image is sent by the soundbar to the tv. And because all my devices are supporting hdmi-CEC, the source goes auto any time when i shut on/off anything.