Acces HDD on USB Vero in Win10

Is it possible to acces a harddisk connected to the USB port of a Vero4K+ on windows10?


If you install the Samba (SMB) Server from the MyOSMC App store. It should share your USB Hard disk, so Windows 10 can see it.

Thanks Tom.

Once you have Samba server running you can just open an explorer window (win+E) and in the address bar type in two backslashes and then the ip address of your OSMC device (ie \\192.168.x.x)

1 Like

Samba is running on the Vero but i cant acces it.

Can it be because they’re noy in the same network segment?
Because my pc starts with 192.168 while the Vero starts with 10.0

Should be fine as long as you have routing between the two networks and no firewall blocking.
So what happens when you enter the IP in the explorer?
Also can you access the Webinterface of the Vero from the PC?

I’ll get a time out.

How do i access the Webinterface of the Vero from the PC?

Check that it is activated Settings → Services → Control → Allow remote control via HTTP and then just type the IP address of the Vero in your browser.

1 Like

Yep, its turned on.
Still cant reach on the pc, but… i can reach that via my ipad.

This is the case: My pc is connected by wire to the main router. From there a UTP cable goes to an Apple Airport which has a built in Switch. In that Switch is the Vero.

Now, when i’m trying to acces the Vero on the iPad while wirelessly connected to the main router, i cant acces it. While connected to the Apple Airport, i can.

Seems the problem is that there are 2 network segments that are not able to communicate with one and other.

Yep, clean up your network

Will do. Thanks for the push in the right direction guys

Some time ago, don’t know if it was PEBKAC or some broken .conf file .

I could not for the life of me connect to hdd shared on my Vero from windows, i check locally on vero the drive was shared, I would get a permission denied, so it showed signs of life.

So I did what came natural for me,

sudo smbpasswd -a osmc

In hind sight, it might have been an dist-upgrade that overwrote OSMC smb.conf with debians default.

Might be worth a try.

1 Like

If your going to use a second router as an access point you really should make sure that the secondary one has DNS and DHCP turned off so your only using the switch and wireless parts of the device. You also don’t normally use the WAN port in this setup on most devices (ie non reconfigurable WAN ports).

1 Like

Both my routers are now in the same network segment and i can acces the Vero webinterface by browser. I even see a network share in \OSMC called “osmc home directory”.
I just can’t seem to get acces to the network share though, prompting me the credentials are incorrect.
I use the same username and password to successfully login to the webinterface


Web interface and samba have different passwords, please follow the instructions post @joakim_s; to set a new password for samba:

Thanks Tom.

1 Like

Thanks Tom and Joakim, but you’re dealing with a noob here, i have no idea what “sudo smbpasswd -a osmc” this means…


You need to issue it via the command line:

It will reset the samba password for the osmc user, which use you need to login in as to connect to the share.

Thanks Tom.

1 Like

I attached a USB keyboard and entered the command line and that did the trick , i can now see the USB HDD in my Windows explorer.
Next in line of obstacles is that i can’t write to the disk, the medium seems to be write protected. Do i look for this in Windows or is Kodi perhaps denying me privileges?
ps. I do have full acces to the default osmc folders though.

Edit: a USB thumbdrive in the same USB port on the Vero can be written to

Edit2: Works now, had to do with the way i had created a network share