Access denied after aug update

After August update, I cannot access to my osmc via SSH(with putty)

Whenever I try it, I get the message “Access denied” even though I put the right ID and password, which is the default one.

Fortunately, keyboard and mouse are working, I tried to reboot several times and tried to access again but the result was same.

I tried it tens of times and it’s not the problem of mistyping.

What can I do?

Can you login via console (instead of ssh)?

Sorry but how can I try it? I have no idea how to change it from Kodi to command line.

Plus, interesting point is that FTP is not working, but SMB and transmission are still properly working

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Well FTP uses the same authorization as SSH while SMB and transmission has their own.

thank you for your help

I tried to access locally with osmc/osmc, but it is also denied saying “Login incorrect”

Which means your /etc/passwd is either changed or damaged.
You could do some open heart surgery by putting the SD card into your PC and edit cmdline.txt and set init=/bin/bash
and then boot it into a root shell.
Than you could first check the /etc/passwd file, if it looks ok just use passwd osmc to reset the password.
But you might actually still need to figure out what happen which could be:

  1. Someone got hold of your device and changed the password
  2. You have file corruption which would indicate a failing SD Card

You can check the last password change date with passwd -S osmc (use sudo if not root) and see if it corresponds with the date from ls -l /etc/shadow.

If it has not recently been changed, then a card problem seems more likely.

As far as I understand, after setting init=/bin/bash into my cmdline.txt, it should boot into a root shell immediately. But although I set it, it boots into Kodi as usual.

Are you sure your card is committing those changes?

Some cards silently fail and become read-only; but the controller pretends that the changes were written. Can you post output of cmdline.txt here?

Also: if you’re on a NOOBS install, make sure you’re changing the right cmdline.txt

yes I belive so. mine is like below

root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp1
init=/bin/bash

Looks like you added an own line for it, it should be part of the first line.

oh you are right lol

i eventually got into the root shell and solved the problem simply running passwd osmc

thank you so much all u guys!!:grin:

Well as mentioned you might still want to figure out what happen.
Because it is for sure not normal that it happen and must be related to one of the two points I mentioned.

I have the same issue since the last update, and let me tell you that it’s for sure an abnormal behavior.
Let me explain how and why:
Today I rebooted via SSH remote console (via putty).
Result: after the Pi came up again my OSMC user and password did not work anymore - “Access denied”
I rebooted the Pi once more - it worked again.
Another reboot - same as before - Access denied.
Another reboot - Access denied
Now I am trying to reboot for the 4th time in a row, and still my user and password are not accepted anymore.

What the heck is going on here?? And how do I get back to my console now?
Is there still any root account or something? I renamed mine and only work with that one, which is the one which shows that weird behavior now.

Most likely an issue with your SD Card

You can try with a keyboard attached, then Exit and press ESC. If you also can not login there your only path is the Rescue Console

I just unplugged the power and then plugged in again. Before booting up it said:
“Waiting for root file system - recovering journal” => is that a hint that my memory card might in fact have an issue?

And how to get into that Rescue Console?

Yes and no, that first basically you means “I need to fix the filesystem that is “dirty” after someone unplugged the power without clean shutdown”

If I remember correctly it is hold “SHIFT” while booting.

Does not work for me.

Seeing that everything but the remote console still works like a charm, may I ask why at all you assume it’s the SD card having an issue?

Strange, you might need to press it a bit faster or maybe it is CTRL.

Well if you can not login anymore there are generally two options:

  1. A broken filesystem either broke the password file or doesn’t allow your session be written to disk
  2. Some one has changed your password.

While it can also be the second one I hope for you it is the first one :wink: