Access my vero 4k+ shared hard drive with my Pi 3

Hi All, I’m trying to access my vero 4k + shared hard drive with my Pi 3.
In the OSMC menu I go to Videos, files, add videos, Browse.
Here I have several options but only Zeroconf browser seems to see my vero share.
In Zerocof browser I can see: Samba Shares on osmc ( SAMBA), when I select this i see folder: osmc and Vero hd 2TB ( what I named it). Selecting either of them I get notification File exists.
I have no idea what else to do. On my Win10 pc I can acces the vero 4k+ hard drive with no issues. I remember entering username and password there which is the standard one.

Can someone help me with an easy step by step guide, I have no experience at all with Linux :frowning:

On you RPi go to the same place but set the maximum value to smbv1 and reboot. Once you have rebooted you should now be able to go to videos>files>add videos>browse>windows network (SMB)> and you should now see your Vero and select a file path. When it pops up give it the username “osmc” and password “osmc” and check the box for saving these credentials. Once you are done setting up your sources I would recommend going back into your settings on the RPi and change the maximum protocol setting to smbv3.

Thank you darwindesign, I had it working immediately.

1 Like

I’m unable to reconnect my Pi3 to my Vero shared hard drive after updating to August Kodi 19.1. When I browse to OSMC in windows network I receive " connection refused" error. I’m still able to access my Vero hard drive with my win10 pc as before. Is there another process to follow?

Below is the log:

As seems you are limiting your SMB Protocol to Version 1. Go to Settings - Services - SMB Client and increase that to 3. And try then.

I increased it to 3 but still unable to access.

Are you sure this hard drive is still plugged in and powered on? Can you access it on the Vero itself?

Yes hard drive is plugged in and accessible with the Vero and also with my Win10 pc over the network. I tried reinstalling 2020.11-1 on my Pi 3 and it is still not working. The only other thing I can think of is that my Vero is now running the August update, maybe that is causing the issue? I was even able to access the Vero hard drive with VLC on my mobile.

Instead of zero conf I would try manually adding the Vero as a network location and see if that works. You would go SMB and click the add network location and then manually type in smb://192.168.x.x/ replacing that IP address with whatever your Vero is using. It would be strongly advised to have your Vero set to a static IP when you do this. You should then have under adding a SMB source a network location showing that IP address and you should be able to browse it similar to as you did using SMBv1

Thanks for your help darwindesign, I was able to access by using zeroconfig browser.