Access to A Replay Volume Control Kodi 17.1 May 2 2017 Pi3B

Just got updated to Kodi 17.1 (Compiled May 2 2017)…
The default music replay level was at minimum making it too low on TV:HDMI playback unless TV volume set to max (nightmare switching between Kodi/TV). The only way I could find to change audio replay level was using my moby as a remote and using its volume buttons.

In a previous version I recall a menu resetting for default replay volume. I’m stuffed if I can find this now. Just spent 6 quid or so on a mouse to control Kodi via TV screen and it would be nice to also be able to control current replay volume on-screen without needing to find my moby as remote or the TV remote.

So… Is there any way to control replay volume while listening to tracks without needing the remote?

Would have thought having a SIMPLE to access on-screen volume control would have been fundamental.

Also: The slide-in-from-the-left-menu is very flaky and needs to persist longer to be able to get to options and be usable.


If you bring up the OSD display and enter the menu that looks like a speaker (the third one from right) Can you adjust the volume there?

Thanks Tom.

Depends if you are using passthrough. If audio only volume will work fine

It should persist until you dismiss it

(Thanks for replying)
I am using what I assume is the default skin and haven’t yet found any others.

I’m not clear what the OSD display is. What I take to be the main KODI menu list my options: Music, Add-ons, Pictures, Videos, Favourites and My OSMC. Along the top I have the Power icon, System icon and Search. With something playing I also get a Diamond. To the right I get a display access to the library tunes.

Selecting thro to a tune or Clicking on the Diamond takes me to a “Now Playing…” screen with a what could be a record player and a play-progress bar and on moving the mouse I get the |<, || and (restart, pause & stop) on the left and * -> => Lyrics and Gear (rating,repeat, random,… settings). With music playing here I have no access to any menus and am trapped here until I press (STOP). Would expect to have (easy) access to VOLUME control here and any other screen while tune playing. Have tried left/right mouse and wheel.

Selecting music files from a directory in the bottom left I get “<@ Options”. Clicking “<@” the side menu slides in from left giving me “View Options” menu with play controls (if playing) plus file list options. Clicking “Options” gets me the same. I have to be quick here and get to an option else the side menu goes away too quickly. Still not found a SPEAKER icon.

Also, TV remote doesn’t work, it did. Tried power cycling TV and rebooting. Got it going on Kodi 17 after reading info here: Sony TV.

Also, with “Player Settings->Music->Play next song auto = ON” it doesn’t. Previously selecting a tune from library would keep going to next tune.

Could go on but…


The osd display that looks like this:

Is there meant to be a link there?

Is remote working now? Or had you got it working and now its failed again?

Thanks Tom.

Sam, the side-slide-in-menu will only persist if the cursor is actually on and item. Once captured this menu will slide away when the cursor is moved slowly to the next item. Moving quickly to the next item will retain this menu’s presence.

Clicking and holding cursor on “Options” (bottom left) and the menu will appear and stay. Moving cursor other than very (very) quickly to select an item and its gone.

Not using “Pass through”.

Just found OSMC Skin and mouse selection on the Music vertical list is near impossible. Cursor skips up/down multi-lines, mouse wheel is just OK. On Estuary (default skin) the mouse wheel is impossible while cursor selection is OK. Go figure!

I’m using very cheap wireless mouse (without keyboard) from “Compoint”

Thanks All.

I’m using the OSMC remote here, and when I press the Left arrow to bring it up, it stays there until I perform another action.

It might be different for a mouse. @BobCratchett may have some suggestions.


Oh Wow! Like it! However, I don’t get anything like that full on screen display nor anything like the side menu shown below it nor when I’m playing video files.

I’m using the default Kodi skin (which now seems very boring).

Re: TV Remote: My Sony BRAVIA has a menu offering me “TV control with the TV remote”. Previously I could toggle this to another option but not currently. Tells me is only available for BRAVIA Sync compatible devices. TV remote did work with pre-Kodi 17 and the first release of 17. Not now with 17.1 complied 2 May 2017.

Interestingly: just found access to a sound level control while playing a video under “Audio and subtitle settings” using the bottom right “Gear” symbol on play video.

Guys I’ve cracked it (well sort-of):

Under “System->Settings->Skin settings->General” menu there is a “Touch Mode” option. This was originally OFF.

Selecting “Touch Mode” to ON I now get at the bottom left screen a Speaker Icon, Favourites Star and Settings Gear (who’d have thought?).

Selecting “Speaker” pops up a drag block that controls volume. I have it full which gets me a sound level compatible with normal TV operation. However, these extra options disappear when returning to the top Kodi menu and aren’t there in the “Now playing…” screen with the track progress bar.

So, not a complete fix as this volume control access ain’t always there when you need it. It’s also a real bitch getting out of the “Now playing…” screen using the mouse. Seems random right button clicks will exit this screen but control is vague.

Interestingly my Sony BRAVIA external device control option now toggles to “Device control by TV remote” but Kodi is still doesn’t respond to the TV remote. Some how this control on TV works regardless of “Touch mode”.

Still only getting one track played and no follow on to next. I’m not using play list just directory list and select. This worked in earlier versions.

This can be brought up by pressing a button on your remote, according to to link I’ve provided it will be: ↵ Enter or M or on remote the OK (or the equivalent button on your remote control. On my mine its list. I know your tv remote isn’t working at the moment, so can you please do the the following:

Please enable debuging logging, details can be found here, and enable component specific logging, for libcec. You find this is logging section on osmc aswell, Hopefully this will show why your sony remote is no longer being picked up.

Can you show this on the debug logs aswell?

Thanks Tom.

Apologies for delay in replying, Labyrinthitus: like being totally drunk plus a big hangover and the bonus total loss of sense of humour. Plus it lasted for over 2 weeks.

Thanks guys for your input. The original volume issue is solved as outlined above (see Touch Mode) and, after fiddling with Sony TV set up and trying a desktop version of Kodi the remote started working and that followed back to my Pi3b Media system. So all good. The remote on my cheap TV still doesn’t work but that should be another thread.

Would appreciate having improved access to a volume setting in all audio play screens suited to using mouse control. Video modes seem to already have this. Generally mouse control needs more work. I have debug logs from just before I was struck down but they may now be out of context.

Will search other threads for “auto play next track” not working before raising my head again. Thanx.

Another forum thread gave a great workaround for CEC users: "use Kodi’s Keymap Editor addon. Defined two numeric key to volume up/down and it works! ". My cable provider’s remote (programmed to control my TV) has many buttons that I never use that make the TV send CEC events to kodi. Configuring Mute, Vol+,Vol- keys in kodi works great to allow kodi to control the speakers connected to the TV’s optical audio out.