Access to movies over WiFi but not Ethernet (NAS)

Hi all,

I am using a QNAP NAS that was successfully streaming movies to my Vero 4K over WiFi. Due to bandwidth issues and buffering, I have now run an Ethernet cable to the Vero 4K but the movies can’t be accessed.

I am using NFS, and can see my movie folders in the library. However, over Ethernet Kodi can’t seem to open the individual movie folders/see the content in them.

There does not appear to be a file permission difference between the WiFi source and Ethernet source - i was able to update and populate the library, as well as watch the movies before when it was WiFi based.

The NAS has been set up to allow the Ethernet IP of the Vero 4K and has handed over the movie folders, but maybe there is some other permission required now it is over Ethernet?

I have tried: -

  • Restarting the Vero 4K & NAS
  • Updating the library
  • Double checked the ‘Change Content’ page to select the movies within named folders option

Any assistance would be greatly appreciated.

Edit: I can move the movies out of their own folders, and Kodi will pick it up, add to library and get the artwork etc. However when I press play they just refresh rather than open.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I suppose you have different IP’s on WiFi and Ethernet.
Check the access list on your NAS NFS server if the ethernet port IP is allowed.

Thank you for the instructions, log file here

It appears that access is denied “‘open call failed with “NFS: ACCESS denied. Required access r–. Allowed access —”’” but the setup is the same as the WiFi connection was.

I have also added the Ethernet IP address, and as mentioned they are communicating as it has built the library from scratch but can’t open the movie files.

Hi Smurphy, thanks for the suggestion - I have made sure the Ethernet IP has been added, looks to be working as it has built the library from the NAS files, it just can’t access/open them somehow.

Suggest to login via command line and run
showmount -e
Post the output here

I’m not familiar with the QNAP but that’s the most likely candidate for the issue.

I don’t know if it does any MAC address filtering or gets grumpy with a change of MAC address against a known IP but a reboot of the QNAP followed by a reboot of the Vero should fix that if it is the case.

Looking at the QNAP pages you can assign access based on IP or subnet - which did you setup? It may work better opening a subnet/IP range and would stop you having the move the IP if you change between WiFi and ethernet on the Vero.

Hi fzinken,

I get:

Public *

Is that what you were looking for?

The first IP is the Ethernet, and second the WiFi that I assumed I had disabled. Both are granted the same permission within QNAP software.

On QNAP I have granted it Read/Write access to the ‘Movies’ folder, and applied it to all subfolders. I notice you can’t grant subfolders access directly, and wonder if this is a QNAP problem?

Weird that it worked on the WiFi mode though…

Hi eightiescalling,

Thanks for the suggestions.

I have assigned access by IP, which I had done for the previous WiFi connection. Good point regarding the changing IPs, but I leave these devices on pretty much 24/7. It also didn’t seem to be the issue with the WiFi connection that worked.

Yeah looks good. Maybe a protocol issue, can you check which NFS versions are configured on the QNAP?

Thanks for confirming it looks ok.

NFS V2 & V3 are enabled by default, I also enabled V4 as part of the troubleshooting but that didn’t seem to change anything. Unless there is a setting on the Vero that I need to tweak?

Thanks very much for the help so far.

Ok, I would stay with v2/3.
Anyhow, so you confirm that it is working as soon as you use wifi? Can you upload a log file for that case.

Hi fzinken,

The WiFi option is no longer working either… It was working before the Ethernet setup though.

I think I may reset the Vero 4K and setup again.

Well my gut feeling would be the QNAP changed (e.g. firmware upgrade).

Also when yo do a reinstall you might want to switch to fstab or autofs mounting instead of the Kodi NFS access as it is more performant and easier to troubleshoot.

Yes, I am going to have to try roll back the QNAP to the last update.

I have implemented fstab, which was able to access to movie folders but not the files. Upon restart, it could not access the movie folders at all - even though no permissions had changed.

I also reset the folders/QNAP box itself, but still no luck!

Will roll back the NAS and update here after.

Rolled back the NAS, and reinstalled OSMC on the Vero 4K but still no luck.

I am going to blame the NAS for this - if anyone has any experience with a QNAP NAS setup it would be much appreciated :slight_smile:


EDIT: SMB works as expected. I can’t find anything concrete, but suspect QNAP has an issue with NFS.

Within the file security settings, you can grant access to the OSMC IP for the Share, but not specific subfolders within the Share. I have also seen one other post online about not getting permission to access subfolders.

Thanks to everyone here for helping out along the way, I made a small donation to OSMC to say thanks.

Probably QNAP share default settings.
In fact, make sure that the Movies folder can be “read” by anyone in your LAN.
By default, a shared drive is locked to the user owning the share.

This thread is missing a simple test. We need to see what happens when you try to mount an NFS share from the command line:

sudo mkdir /mnt/public
sudo mount -v -t nfs /mnt/public

If it appears to mount correctly, run:

ls -la /mnt/public

Show us the output from the above commands.

1 Like

Well kind of had that covered

You sure your Vero has a statically assigned IP Address? If upon restart it changes, it can mess with the accesses provided by the QNAP (if based on IP).