Accessing sidebar

I am running OSMC with the default OSMC skin on a Raspberry Pi 3, using the official OSMC Remote to control it, which works nice except for one thing. I would like to be able to access the sidebar menu (the one, where I can set the sorting, view type, access the Current playlist, etc.), but unfortunately, it doesn’t seem to be possible out of the box.
I can easily access the menu when I connect a mouse by moving it to the left of the screen (as described in the Kodi wiki here.), but I haven’t figured out a way to do it with the remote. I don’t wan’t to use a mouse (or a keyboard for that matter) from the couch for obvious reasons, though.

This is very annoying especially because there is no way to show the Current playlist when playing music, but I would like to use some of the other features available in the sidebar menu as well.
Am I missing an easy solution here? Is it possible to remap one of the buttons on the remote to do this somehow? Is this maybe a skin issue? I do like the default skin, but I’d definitely consider another one, provided this would work in it.

Any help is much appreciated.

Tried to press left on the remote while in a list view?

Sure, I thought it would work like this, since it is described like that in the link I posted, but no matter how many times I press it, it doesn’t do anything. I think it also doesn’t work with the keyboard, although I will have to check that to make sure.
Should it work like that even on OSMC skin? My conclusion was it is probably a Confluence feature that doesn’t work on OSMC skin.

Just checked and if I press left in a movie or music list I can access the menu without problems. On rpi2 latest osmc with original osmc remote and osmc skin.

Works exactly like that for me on OSMC skin. From what menu are you attempting to do this?

I tried it from several different menus, the one listing songs in an album, the one listing TV show’s episodes or when showing movies, to give a few examples. (Although the movies one might not be a good example, as I use the thumbnail view there.)

Did you have to set up the remote somehow? I did select it under My OSMC -> Remote.

I should also mention that I am using the HifiBerry Digi+ board on my Raspberry and I disabled the GPIO LIRC remote support as instructed on the HifiBerry website: https://www.hifiberry.com/guides/supportedsoftware/. I assume though, that it is not the problem, as the official remote is not an infrared remote.

I simply plugged in the remote.

You are using the right profile for the new osmc remote right? I have the old white ir one.

I have the new style black remote. I suspect same as OP.

I have the black one as well. An I notice now that there is a picture of a white remote next to the conf file I chose, which is called osmc-remote-lircd. So this is the wrong one? I don’t see any other entry for an OSMC remote.

Yes revert that. No need for any config.

So, I reverted the remote setting in My OSMC by manually deleting the symbolic link in /etc/lirc (didn’t find any way in the user interface to do it) and there is now no remote selected in that menu. More importantly however, it also didn’t help, everything is behaving exactly as it did before.
I also tested again with a standard keyboard and when I press left arrow there in any of the menus, it also doesn’t do anything. Is this possibly an indication of another issue, not actually connected to the remote itself?
(With the mouse, I can still access the menu by moving to the left of the screen.)

Can you try to deactivate mouse support in the settings and/or unplug the mouse?

I only plug in the mouse occassionally, so it is definitely not helping to just unplug it. I’ll try to disable mouse support, though.

Did you try a reboot or at least a restart of Kodi after removing the link?

I rebooted from the OSMC power menu.

So I tried disabling mouse support in settings, but it didn’t make a difference :frowning:
Looking at the fact that I cannot get to the sidebar even using a standard USB keyboard, I am starting to be convinced there is something more fundamentally wrong with my install. Although, I am not a complete beginner, it was my first install of OSMC so there is a possibility that I screwed up something somewhere. It seems to me that the next thing I will have to try is to do a fresh install on a new sd card.
Or does anyone has another suggestion what I might try to fix this?

Unless you are just trying to preserve this installation on this sdcard, I’d just fresh install on the same card to start with.

Did you say that this works without issue if you switch skin to confluence?

Well you could provide debug logs that show the behaviour when you press the left arrow.
The only thing that you fundamentally could have done wrong is to configure the left button differently. For a quick check with out reinstall do:

sudo systemctl stop mediacenter
mv .kodi .kodi.backup
sudo systemctl start mediacenter

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

I haven’t tried Confluence yet, will do!