Accessing SMB share: "File exists" / "Operation not permitted" errors


I received my Vero 4K+ today and just hooked it up.
I have been using Kodi for many years now, so I’m quite familiar with most of the stuff.
For some reason, I can’t access my samba shares with the Vero.

When adding a source like smb://MYSERVER/tvshows, I get a “File exists” error and am unable to access the share.
I can find and browse the shares through zeroconf, but trying to add a directory results in an “Operation not permitted” error.

I tried adding some shares “forcibly” by adding entries to the sources.xml and passwords.xml files, but I still can’t access them.

What does work is adding those shares to /etc/fstab and mounting them, but I’m synchronizing all my Kodi instances through a MySQL-DB and the file paths stored in there are all referencing the samba share.
So using local mount points is not really an option for me.



What are you using a Samba server: a Nas, router, Winders Server or Linux Server?

What samba versions does the Samba server support?

Whats the entry, will probably help configuring local shares.

Thanks Tom.

Since mounting works via /etc/fstab but not in Kodi, this sounds like an SMB version problem. You can edit ~osmc/.kodi/.smb/smb.conf to set the same version as you used on the fstab mount.

You can also use path substitution so that any time Kodi tries to access smb://MYSERVER/tvshows it will be redirected to /mnt/tvshows.

I turned on debugging in Kodi and get this when trying to access a SMB share:

20:14:29.808 T:4077986384   DEBUG: OnKey: 11 (0x0b, obc244) pressed, action is Select
20:14:29.841 T:3794383616   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://USERNAME:PASSWORD@MYSERVER/TVShows'
                                            unix_err:'1' error : 'Operation not permitted'

and this:

20:15:11.265 T:4077986384   DEBUG: OnKey: 11 (0x0b, obc244) pressed, action is Select
20:15:11.311 T:3794383616   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://'
                                            unix_err:'11' error : 'File exists'
20:15:13.002 T:4077986384   ERROR: GetDirectory - Error getting smb://
20:15:13.002 T:4077986384   ERROR: CGUIDialogFileBrowser::GetDirectory(smb:// failed

Thanks for replying!
I’m running Samba 4.8.3 on Centos 7. I’ve set “client max protocol” to SMB3.
That config did work with Kodi 17 on LibreElec until I got rid of the device a few days ago.

The fstab entry on the Vero looks like this:

//myserver/tvshows       /mnt/tvshows    cifs    rw,credentials=/root/.smbcredentials,uid=1000,iocharset=utf8,sec=ntlmssp,noauto 0 0



Please post the contents of:


Thanks Tom.

Path substitution would work, I just tried it.
But newly discovered library items will get added to the database with local paths then, so I would need to add path substitution to my other kodi instances as well (just for the reverse direction).
That’s not a big problem, but I’d prefer a cleaner solution if there was one.

I’ll try to fiddle with the ~osmc/.kodi/.smb/smb.conf file tomorrow and see if I can get it to work.

I haven’t changed the ~osmc/.kodi/.smb/smb.conf file yet, so it still looks like this:

        lock directory = /home/osmc/.kodi/.smb/
        client max protocol = SMB3
        name resolve order = bcast host
        include = /home/osmc/.kodi/.smb/user.conf




looks good.


The solution to this is to have one “master” machine that does all the scanning and database cleaning, and then the other systems will magically see all the changes with no work, as long as the path substitution is correct.

1 Like

So, under System->Services->SMB Client I changed the workgroup name to reflect my Samba server’s WG and also entered the WINS server address - now I can access my SMB shares.
I also changed the max client protocol from SMBv3 to SMBv2 there, but changed it back to SMBv3 later and everything still works - so that probably wasn’t it.