"Acestream not installed" error

Ok so my previous thread got removed cause we started talking about 3rd party apps. I’ll stick away from that this time.

Has anyone actually gotten an Acestream link to open successfully on these Vero 4k boxes?

I’ve installed the acestream.apk manually from the command line. I had to do this cause no matter which repository I tried to install it from they all failed.

Any time I try to open an acestream link I get the error, “Acestream not installed.”

It doesn’t matter which app I try to open the links from I get the same error.

Thoughts?

This thread might help: Acestream

That talks alot about RPi2 is that the same as ARM7 ???

Yes. If it works on Pi 2 / Pi 3 it will work on the Vero 4K.

I see you posted over on Reddit: https://www.reddit.com/r/OSMC/comments/72m0js/osmc_on_arm7_need_help_with_acestream/

That subreddit is mainly managed by us. Let’s keep the discussion in one place if possible.

Sam in that link it refers to two different methods. Which one were you referring to specifically?

Haven’t used AceStream. No idea. I’d pick the last post and give that a go.

I got acestream to work with vero4 but only when i use commands:

cd /home/osmc/.acestream
./start_acestream.sh --client-console --live-cache-type memory --live-cache-size 20971520 --live-buffer 60

but how do this automatically from systemd?

I think it comes with a systemd unit. But best check with them

OK acestream working now but i used docker method
how to:
1. Need to install docker:
You need root so first command sudo su
then

apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D
apt-key adv -k 58118E89F3A912897C070ADBF76221572C52609D 
mkdir -p /etc/apt/sources.list.d
echo deb \[arch=armhf\] http://apt.dockerproject.org/repo raspbian-jessie main > /etc/apt/sources.list.d/docker.list
sleep 3; apt-get update; apt-get install -y -q docker-engine

now you have new repository and docker engine run docker deamon systemctl start docker

2.Install acestream

For installing acestream you need put service file acestream.service directory /etc/systemd/system and run with systemd:

curl -sSL https://raw.githubusercontent.com/aaaler/acestreamproxyvlc-pi/master/acestream.service > /etc/systemd/system/acestream.service
systemctl daemon-reload
systemctl enable acestream
systemctl start acestream

After this docker download and install docker-images ,you need wait little bit.Now acestream working port is 62062.

Installing Docker to run a systemd unit is slightly excessive; but I’m glad it’s working for you now

Sam

ok and now easy way you need to be root :
sudo -s

cd /home/osmc/.kodi

wget https://www.dropbox.com/s/2pl9bmy59896j0e/acestream_3.1.24.2_ARMv7.tar.gz?dl=1

mv acestream_3.1.24.2_ARMv7.tar.gz?dl=1 acestream_3.1.24.2_ARMv7.tar.gz

tar -xzf acestream_3.1.24.2_ARMv7.tar.gz

and systemd:

 curl -sSL https://www.dropbox.com/s/p527w7swkv56vxj/acestream.service?dl=1 > /etc/systemd/system/acestream.service

 systemctl daemon-reload

 systemctl enable acestream.service

 systemctl start acestream.service

after you can check its everything is ok

systemctl status acestream.service

and you see somthing like this

1 Like

Thank inahike for your instructions and your help!
I came quite far - but then came a bad message - what went wrong? who has an idea?

Yes, would be great to have a instruction for newbies

You ran

curl -sSL https://raw.githubusercontent.com/sybdata/acestream/master/acestream.service1 > /etc/systemd/system/acestream.service 

but the file isn’t acestream.service1, it’s acestream.service (without the 1).

ahhh - thanks for the quick answer - try it now

worked very well - thx

instruction for newbies:
1, at first a have to go to the command line: https://osmc.tv/wiki/general/accessing-the-command-line/
2, cd .kodi/
3, wget http://cloud.sybdata.com/acestream_3.1.14.tar.gz
4, sudo -i
5, curl -sSL https://raw.githubusercontent.com/sybdata/acestream/master/acestream.service > /etc/systemd/system/acestream.service
6, systemctl daemon-reload
7, systemctl enable acestream.service
8, systemctl start acestream.service

exit - done

So are you absolutely sure that the file is acestream_3.1.14.tar.gz5? :slight_smile:

2 Likes

I’m not really sure - it worked for me perfect and the ace stream engine runs