Add fonts for subtitles

Hi everybody
I would like to add calibri font in /usr/share/kodi/media/Fonts but I keep getting this message all the time “permission denied. Error Code 3. Error message from server: Permission denied”
Is there a way to have access to this folder? I’m using winscp.
I tried in transfer settings to be able to read and write but I can’t change anything because of the permission

Install it in to your .kodi’s home folder instead.


Thanks for the quick answer but…
In this folder “/home/osmc”?
just drop it there??


I think it would be .kodi/media/Fonts.

You can of course use sudo to move the files in to /usr/share


Thank you very much, with sudo it worked!

The problem is, when we push an update to Kodi, your changes here will be lost. If you place these files in /home/osmc/.kodi/media/Fonts/ then they should survive any updates.

Thanks for all the replies. I am getting server response 553 cannot create folder error while trying to ftp the font. For now that’s the only problem I have. Things are getting better thanks to you guys.

Tried this but couldn’t find /home/osmc/.kodi/media/Fonts/

So tried this but couldnt upload /usr/share/kodi/media/Fonts/

I tried sudo first time in my life. It works now. Thanks.