Add new remote to OSMC

Hello, I am have purchased a case called Mediapi+, and it comes with a remote using the gpio ports and an IR sensor on the front, there is a tutorial on the website but it is not fit for OSMC, I am hoping someone can point me in the right direction as to where too add the remote config file to enable the remote, I know the IR sensor works as I have changed a setting to use a spare xbox 360 remote I have lying around (but it has alot less functionality than the other remote when set up). I have had a search through the forums and can’t seem to find anything.

above is the walkthrough for setting up the remote on openelec, but OSMC is much better and I am hoping to get it working! any help is hugely appreciated,



From the linked page:

copy lircd.conf to /storage/.config
copy Lircmap.xml to /storage/.kodi/userdata

IN OSMC you can put lircd config anywhere, probably best in /home/osmc/.kodi then in MyOSMC>Remotes in the bottom right select browse and browse to it.
The other file would go in /home/osmc/.kodi/userdata

Ignore the rest of the tutorial as it’s already done in OSMC

Legend, ill give that a go, I was searching everywhere for the /storage/.config folders! Didn’t know the OS did it for me!



Update: you have to add the root menu in the file manager, and .kodi is not a file accessible in the browsing for remotes, so I changed the location of the lircd config to /home/osmc/pictures and added the root in file manager and your suggestion worked a treat!

Cheer Diligaf!

It’s quite accessible. It’s just that the . placed in front denotes it as a hidden directory in Linux. Maybe some of the info I’ve provided here can be helpful for you Cheatsheets and Tutorials for users new to Linux based operating systems - #2

Wouldn’t it be better to put the config files in /etc/lirc with the rest of the lirc configs?

sorry I wasnt very clear, I managed to put the file in there, just couldnt browse for it using the browse function in My OSMC, Remotes, Browse. apologies for the ambiguity on my part.

No, because things there are overwritten on update. That’s not true of items in /home/osmc.

I’m not sure I follow, I can put the file in there using ssh on filezilla, but when it comes to browsing for the remote on the on screen display, the .kodi file doesnt appear, so I cant retrieve the config file, unless I am doing something wrong, I am quite a noob! further to that I now that I have it working, is it possible to remap the buttons using something like notepad++? I assumed the remote would be very useful…but with no back button I fear I my have been made the ass.

Keeping it in your home directory is perfectly fine. It will never be overwritten there and you’ve pointed the link to it within MyOSMC. Not a big deal. But there is a reason you can’t get to hidden areas within Kodi. You haven’t yet enabled it.

Ahhhh see theres my noobiness showing through! shall change that now! is there a way to remap the buttons though as with no back button its pretty much useless!

The Kodi wiki I’ve linked you to is your friend…

took a bit of hunting but and trial and error but its always the best way to learn, thanks for your help both of you, really appreciate it :slight_smile:

Fair enough.

Though he could submit it to the repo for others to use as well and then it would be included in future updates.


I’m thinking about buying this case for my dad. A Pi+Hub+Hdd scares him :wink:

How has it worked out for you?

He has no internet, so I plan on setting it up with all the movies and TV I have available