Add on- error Cannot Update. Update done 1.3.16 ... so still there

Continuing the discussion from Manual Update Not Working:

Same errror (same as frenchdj) I 've done the upgrade this morning 1.3.16 …

Enable debugging and provide logs

Hello

Here is kodi.log file

NOTICE: -->Python Interpreter Initialized<–
10:08:30 156975.484375 T:2711614496 DEBUG: CPythonInvoker(22, /usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/call_parent.py): the source file to load is “/usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/call_parent.py”
10:08:30 156975.484375 T:2711614496 WARNING: CPythonInvoker(22): Script invoked without an addon. Adding all addon modules installed to python path as fallback. This behaviour will be removed in future version.
10:08:30 156975.500000 T:2711614496 DEBUG: CPythonInvoker(22, /usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/call_parent.py): setting the Python path to /usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib:/usr/share/kodi/addons/script.module.xmltodict/lib:/home/osmc/.kodi/addons/script.module.beautifulsoup4/lib:/home/osmc/.kodi/addons/script.module.httplib2/lib:/usr/share/kodi/addons/script.module.osmcsetting.logging/lib:/home/osmc/.kodi/addons/script.module.beautifulsoup/lib:/usr/share/kodi/addons/script.module.osmcsetting.networking/lib:/home/osmc/.kodi/addons/script.common.plugin.cache/lib:/usr/share/kodi/addons/script.module.osmcsetting.services/lib:/usr/share/kodi/addons/script.module.osmcsetting.pi/lib:/home/osmc/.kodi/addons/script.module.buggalo/lib:/home/osmc/.kodi/addons/script.module.googleapi/lib:/home/osmc/.kodi/addons/script.module.xbmcswift2/lib:/home/osmc/.kodi/addons/script.module.six/lib:/home/osmc/.kodi/addons/script.module.t1mlib/lib:/usr/share/kodi/addons/script.module.osmcsetting.remotes/lib:/usr/share/kodi/addons/script.module.simplejson/lib:/usr/share/kodi/addons/script.module.osmccommon/lib:/usr/share/kodi/addons/script.module.osmcsetting.apfstore/lib:/usr/share/kodi/addons/script.module.pil/lib:/usr/share/kodi/addons/script.module.unidecode/lib:/home/osmc/.kodi/addons/script.module.uritemplate/lib:/home/osmc/.kodi/addons/script.module.simple.downloader/lib:/usr/share/kodi/addons/script.module.osmcsetting.pioverclock/lib:/home/osmc/.kodi/addons/script.module.oauth2client/lib:/home/osmc/.kodi/addons/script.module.yaml/lib:/home/osmc/.kodi/addons/script.module.parsedom/lib:/usr/share/kodi/addons/script.module.elementtree/lib:/usr/lib/python2.7:/usr/lib/python2.7/plat-arm-linux-gnueabihf:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/local/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages/PILcompat:/usr/lib/python2.7/dist-packages/gtk-2.0
10:08:30 156975.515625 T:2711614496 DEBUG: CPythonInvoker(22, /usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/call_parent.py): entering source directory /usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib
10:08:30 156976.000000 T:2711614496 NOTICE: OSMC settings sending response, update
10:08:30 156976.015625 T:2711614496 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class ‘socket.error’>
Error Contents: (2, ‘No such file or directory’)
Traceback (most recent call last):
File “/usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/call_parent.py”, line 18, in
sock.connect(address)
File “/usr/lib/python2.7/socket.py”, line 224, in meth
return getattr(self._sock,name)(*args)
error: (2, ‘No such file or directory’)
–>End of Python script error report<–
10:08:30 156976.031250 T:2711614496 INFO: Python script stopped
10:08:30 156976.031250 T:2711614496 DEBUG: Thread LanguageInvoker 2711614496 terminating
10:08:30 156976.031250 T:3024945712 DEBUG: ------ Window Init (DialogKaiToast.xml) ------
10:08:36 156981.421875 T:3024945712 DEBUG: ------ Window Deinit (DialogKaiToast.xml) ------
10:08:36 156982.265625 T:2583688224 DEBUG: Thread JobWorker 2583688224 terminating (autodelete)

I am the only one having this problem ?

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

What you have provided is a small snippet of only the Kodi log. This alone will not help diagnose your problem. Please follow Cansa’s link to find how to provide proper debug logs.

http://paste.osmc.io/ubivodaroz

Hope I 've done the correct operation.

So to recap I have the problem when I try to use the manual update.

Thank you for your help

Ok

Very strange in fact, after enabling the debug mode and put the link in the post above I just tried once again

and

I was able to make an update …

So on my side this is solved.

Hope it could help other as well …:grinning: