Add Source missing in file manager

Hi everyone,

Since the latest update 17.6 on my RPi3 the " Add source " is missing in the file manager. Anyone having same issue?

also under video or serie in menu , i cannot add a location for library??

thx for your assistance

regards

Sander

Thanks for giving us more details
To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

thx for your reply…

well more details is difficult, because there are no error messages on the screen.
the locations i added before the update are still there and working
only i cannot add more sources…

here is the link to the kodi.log
https://drive.google.com/file/d/1xscZPBOcbLKgAs1aH_rpwwfdHlLMw8pQ/view

the image shows what is missing in my case…

if you need more info / logs, i will try to upload this evening :wink:

Yes, please upload debug enabled logs via the OSMC log uploader (either via GUI MyOSMC or command line grab-logs -A I don’t like to open files from an unknown source.

is there a way to exclude passw from webdav stored in sources.xml?

not so fond of trowing pw on the internet :slight_smile:

Try the “Sanitizing your logs” part of the link, that @fzinken gave you.

thx guys for the help…all new to this…

here you go with the logs

http://paste.osmc.io/melamidane.hs

@ibizatiger: Is this since you want to correct/change the NFS access to your Synology NAS for all these music files?

I didnt try to change/correct anything on the NAS… Il will take a look @ those settings later… I noticed the errors for music… They have the same settings as movie and series.

Will report back.

So i checked the permissions on the NAS they did not change. BUT… I have no more acces from kodi… Can not acces anything in my Library… Cannot try via SMB, because i cannot add another source location


This is a picture of my tv screen… As you can see no option for adding a source.
The only thing i can do is to change location… So i tried to change to SMB and this is working… For now i have acces but i would like to add movies for my daughter, in a separated ‘smart playlist’ but i cant add a source. Your help is much appreciated… If you need more info i’ll try to provide as good as possible.

Many thx in advance

Sander

The nfs permission on the Syno bases on the ip address. Is on the NAS the same ip used for the nfs allowance the OSMC device has got?

What skin is this? Did you try the standard OSMC skin?

You have both eth0 and wlan0 enabled and, of course, a different IP address on each interface.

So which IP addresses are allowed in the /etc/exports of the server?

Hello guys,
Thx for the reply’s…
I disabled Wlan0 en nfs is working. The ip of Eth0 is authorized on the NAS. So only thing that that remains is the add source problem… I have tried in other skins. This setup is confluence, but i tried also in default OSMC skin and Amber skin. Result is the same… Any idea’s?

The only way I can reproduce the missing Add Source items is (using OSMC skin):

Settings -> Media -> >General -> Show “Add Source” buttons is set to disabled

2 Likes

Can i check this option via putty cmd?
I didint change this option in GUI… didnt even know the option existed.

Thx for the help!

Much much appreciated!

I think in the xml file /home/osmc/.kodi/userdata/guisettings.xml you can find something like

< filelists>

< showaddsourcebuttons default=“true”>true< /showaddsourcebuttons>

2 Likes

solved!! thx a lot guys for your help !!

great support! :+1::+1::muscle:

1 Like