Added a file location but wrongly, now cannot remove entry

Hi there I tried to map my NAS with samba which eventually worked, but now I have another entry in my ‘Videos - bestanden’ page which I cannot remove. When selecting the entry it says “path not found or invalid” and all I can do is select OK. No option to remove the entry but when I created the entry I was in a screen where you could set the entry up but also there was a ‘delete’ (‘verwijder’ as I’m using Dutch version) option there. How do I remove the entry I setup wrongly?
Appreciate any hints…

video>files> highlight source entry, context menu on your remote, remove source. You can also manually remove by editing `~/.kodi/userdata/sources.xml, although I don’t know why that would be neccessary.

Select the videos item from main menu, use remote to highlight the desired source, press c or remote button you have mapped to bring up the context menu, option to remove source will be there.

Hi, thanks but I’m not sure you are correct. I see following

Hope this helps? Entry to be removed is the one that is underlined

There is two different menu actions in Kodi. The picture you posted shows that you entered the menu/slideout menu and that does not give the option you need. You need to use a context menu to access the option to remove the source. If that is the only menu button on your remote then I would recommend installing the keymap editor add-on and reprograming that button to act as a context menu instead of menu. Alternatively you can plug in a keyboard and use the “c” key, use the web interface, or a mobile phone app Kodi remote to activate the context menu.

Hi there, that

menu I did find eventually. This button I hardly use as I mainly watch YT videos. In YT this button is not of very much use.

1 Like

That button on the OSMC remotes will activate the context menu with a normal (short) press and the menu/slideout menu when held down (long-press).

@darwindesign thanks. I also found the option to select subtitles with movies. I could not find that option but by long pressing the STOP button I found that option.

1 Like


I encountered the same problem recently reinstalling OSMC and borking something and couldn’t remove it via the interface. I resorted to plugging in a mouse to right-click and access the context-menu to fix the problem.

My setup is a RPi2 a Harmony 600 remote with OSMC rc6-mce-lircd profile. I programmed the Harmony with an MCE remote.

I have side-menu but not context-menu which is the problem.

I checked the rc6-mce .conf and did not find a context key. Should I be using a different profile? Can I somehow add the context key?


Go to add-ons and install from repository and look for one called “Keymap Editor”. You can use this to change the menu button on your remote to act as the context menu. You will want to do this under ‘global’.