Adding shared folder on OSMC

Good morning,
I currently have a folder on my computer with my movies shared with Upnp software.
I would like to create a folder under OSMC main menu called “My Movies” and tell osmc to scan this particular folder via the network.
But when I go to “Videos”, “Files”, “Add Videos”, “Browse”, “UPnP devices” it does not detect my folder with my movie inside.

What would be the correct procedure to follow here?

Thank you r for your help.

Do you mean the folder itself is not shown or the files are not shown?
“Add Videos” would just show the folder to be added not the individual movies. After you add the folder it will be added and scanned into the library

I mean the folder itself.

No an expert on UPNP, so sorry couldn’t help more

I also tried to do a basic “share folder” on windows but it does not detect it either under osmc.

So you mean you tried to add that via “WIndows network (SMB)” and you can not see it?
I think you will have your network settings or the permissions on that machine.

After having shared my folders on my computer, I go back to adding videos then choosing Windows network (SMB), Workgroup, then I see the name of my computer.
When I choose it it shows me the following message :
Lock Preferences for SMB://my_computer_name

I tried to put osmc/oscm or even blank fields as a combination but as soon as I click on OK it does not go to the next screen, it just hangs in there with the options cancel, OK and New folder.

You would need to enter the credentials of your Windows machine on which you share

I found the solution.
I removed the password requirement option in the network settings on Windows.
When you go back to osmc to add the network folder it detects it without any issue.
There are still a couple of lagging issues with the streaming of the videos but I believe it is just my network capacity.