Adding video source

I know there are many posts about this, but I can’t make it out.
I managed to add my NAS files, from console, and they are mounted in /mnt/Cinema.
However, I can’t see them on my TV when I try to add a video source, either automounted or not.
To complicate things, Kodi instruction page shows a different image from what I see on screen…
Last release installed on Raspi4.
What should I look for?!
Thanks for reading,

If you had configured a mount it should have just been a matter of going to videos>files or settings>media>library>videos and then add source>browse>root filesystem>mnt. Is this what you had done and just not seen your “Cinema” folder or ???

As for the Kodi wiki images if you want to make it a bit easier to follow along you can change your skin to Estuary so your looking at something closer to the images.

Thanks! I got it, it works…
However, I worked straight from on OSMC, as I wasn’t able to change Kodi skin to Estuary, it just didn’t stick…
Permission issue?

More of a Kodi quirk likely. when you change the skin you need to not press a button until it switches and then select OK within the time window when the popup appears least it reverts back. It can be easy by habit to press back or okay after changing it which will revert the skin. Once you do confirm the change it drops back to the home screen which for some reason bypasses the normal writing out to disk of the settings file that happens when you back out of the settings windows. To cure this you should be able to navigate to settings>profiles and then back/return twice to bring you back to the home screen. The setting should be durable at that point.