Additional Audio Encoders

Thought I’d add the FLAC encoder as a distraction from still head butting ripping my CD collection. I now have three Kodi installations on two Raspberry PI units. Two Pi’s use OSMC the third is an application on the Pi desktop. Seems each version of Kodi (All are 17.3) is different in some way or other perhaps because they have a varied install history. I’m simple swapping SD cards on the same unit/usb-DVD unit.

Installing FLAC:
Back to installing FLAC. which describes apt-getting new encoders. I tried installing FLAC on my desk-top install and once on there and enabling it via “My-Add-Ons” found it under the select audio encoder option.

Bathed in success I start up my OSMC:Kodi (recently updated to 17.3) and via SSH entered “sudo apt-get update/ sudo apt-get install kodi-audioencoder-flac”.

After a bit of action I get: E: Unable to locate package kodi-audioencoder-flac.

Clearly my up-to-date desktop version knows where to find it but my up-to-date version of OSMC doesn’t.

What is going on?

It seems the install history of Kodi, either as an application or as an evolved version on a differently dated original SD images gets you a very different functionality. What was to be my primary Kodi 17.3 still won’t rip CD and now won’t play DVDs. A second Kodi 17.3 will rip CDs although occasionally barfs out after a track or two. It’s doing my head in.

After a little more research out there and I find that my add-ons should all be in : “/usr/lib/kodi/addons/”. A quick “ls /usr/lib/kodi/addons/” confirms that the FLAC encoder is there and now, instead of just the two encoders I now have six. They weren’t there earlier!

However, my primary OSMC:Kodi will still not recognize an Audio CD insertion. Seems a data or DVD will pop up the browse menu.

Installing audio encoders from APT won’t work, as you’ll be installing
binary add-ons for a completely different version of Kodi (upstream
Debian version)

You should check Kodi logs for the working OSMC version as it
will have version information