Addons.xml.gz index has wrong digest

Hello, happy user of OSMC since many many years. Today I did a fresh install of the latest OSMC on a new Raspberry Pi 4. Everything works except that I cannot get add-ons from the official repository. I checked that Internet is working, and I can ping the server from osmc.

from kodi.log:
error <general>: CRepository: index has wrong digest ddd1dbf853afd5fceb820e04e302d0e692b87fa21b7c11fb5433fa9e175bc8aa, expected: 1b042469279febb1638951f124bb3714a72f6c518a3c3e1d05a5acf2c091c177

If I test the file by opening in my browser, the website shows the correct hash.

If I download the addons.xml.gz file with wget, and do sha256sum addons.xml.gz, I get the wrong hash… I tried retrieving the file with curl and also get the wrong hash.

Note that the file is actually downloaded from a mirror server (

Is there something wrong on the server in the way the gz file is served to wget ?

Additional info: I downloaded the same addons.xml.gz on a different machine (Windows), connected to a different network. The checksum is also not correct (ddd1dbf853afd… instead of 1b04…).

I am looking, as we had an issue with this last week.

Try it now – seems to be a bug in Mirrorbits. I’ll have to come up with a workaround.

It’s been reported upstream but there hasn’t been a solution


Thanks a lot Sam ! The problem seems solved now, I can access the official repo and have been able to install add-ons this morning.

Hi, I’m having a similar problem after a fresh install:

2023-08-29 00:32:22.244 T:8229    error <general>: CRepository: index has wrong digest 5411a2de585bd8c434abfb88cb60f76bd3b340cc5427dbef4258e6cb5329fa7f, expected: ddd1dbf853afd5fceb820e04e302d0e692b87fa21b7c11fb5433fa9e175bc8aa

Here is what I get if I manually check the sha256 checksum:

wget -q -O - ''
ddd1dbf853afd5fceb820e04e302d0e692b87fa21b7c11fb5433fa9e175bc8aa  addons.xml.gz
wget -q -O - '' | sha256sum -
5411a2de585bd8c434abfb88cb60f76bd3b340cc5427dbef4258e6cb5329fa7f  -

This has been reported as fixed by OP.

Are you sure this is the same issue?

Please try rebooting your device


It’s working now, thank you :pray:

It looked like a similar issue. Kodi was expecting the same digest reported by the OP as wrong one, but was getting another.

Now both expected and actual digests match when I do the checks manually. Could it be that digest is not calculated immediately when addons.xml.gz is updated?

It should be immediate, but there seems to be an issue in Mirrorbits.

Same issue here on a fresh install of OSMC on my Vero 4K+. Log shows:

2023-09-01 23:45:53.843 T:2933 error <general>: CRepository: index has wrong digest 44b31b35bb9160dddbe7682289d00cd8707da27259e8ad462b86fa665dfe6b16, expected: b5863a82b0c534346c2f946c5b80a4e750d4a5a9b0f63d86386e28aee7471012

And I see the same checksum mismatch on a separate machine:

$ wget -q -O - '' b5863a82b0c534346c2f946c5b80a4e750d4a5a9b0f63d86386e28aee7471012 addons.xml.gz

$ wget -q -O - '' | sha256sum - 44b31b35bb9160dddbe7682289d00cd8707da27259e8ad462b86fa665dfe6b16

Is there any local workaround, or do I have to wait for the server checksums to match?

Looks OK here. Which regional mirror are you using?

Thanks, it seems to be working this morning.

I’m in Vancouver, BC, Canada. When I tried last night, the addons.xml.gz file was being served from a few different locations – for requests over a course of around 20 minutes, I got 302 redirected to:

All of these four locations hashed to 44b31b35bb9160dddbe7682289d00cd8707da27259e8ad462b86fa665dfe6b16 with shasum256 locally.

Requesting the server hash ( always seemed to be served directly from, no 302 redirect. I guess it was this hash that was stale, as the four different mirrors all had matching data.

As of this morning, the server hash now matches that of the four files I retrieved last night, and everything works correctly:

wget -q -O - '' 44b31b35bb9160dddbe7682289d00cd8707da27259e8ad462b86fa665dfe6b16 addons.xml.gz

It can fall out of sync for a little bit. I’m working on reducing that time. It’s a mirrorbits bug.

Fortunately it is only particularly noticeable on a fresh install.