Adjust Frame Rate on, lose picture - “invalid format”

Today I setup my new 4k+. Connected it to AVR and LG C8 Oled. When I turn on adjust frame rate and try to play a movie, I lose picture and get “invalid format” on tv or no picture at all and must restart Vero completely to get picture again. When I turn off adjust frame rate, I can watch movies but don’t know if I am getting the best performance. Tried with “always” and “on start/stop” options. What else needs to be adjusted to start using frame rate matching? Is it somehow related to the resolution of the interface maybe? Also, is there an option to match the picture format, hdr, or Vero do this automaticaly by default?


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks Tom.

What’s the make and model of AVR?
Log will definitely help as Tom has suggested


Do you have force RGB enabled in system settings?
I had this error with that setting turned on.

Thank you all for quick respond to my problem.

Before Vero, I had Apple TV 4K connected at the same place with same HDMI cable to my AVR which is Denon x2400h. I bought Vero because I wanted true audio passtrough which Apple TV do not have (and probably never will). The little Vero box is really nice, the interface response is as expected, nice UI and remote.

I left almost all settings at default, adjusted only audio passtrough, switched resolution of the UI to 4k, and tried to turn on adjust frame rate, because I know this is something I used on ATV to get smoother picture. Before I turned on frame rate adjusting I tried few movies to see if Atmos is displayed on my receiver, and movies worked fine. But as soon as I turned on frame rate adj. and played a movie, the sound kept going without picture, with only LG’s display “Invalid Format”. I then tried to go back with “stop” button on remote, but nothing, needed to power off vero and start it again. I didn’t have time yesterday to try different settings, but will later today and post Logs and all.

More info about my system: I use HDMI cables from Amazon, which are Dolby Vision tested with ATV, AVR is Denon x2400h with all necessary settings set to allow passtrough to TV. Maybe devices have to be powered on in a certain order? Or I need to adjust other picture settings on Vero and/or TV, will try.

I will respond later with logs and more details. Thank you! Vel.

It is recommended to leave the UI at 1080p and just enable adjust frame rate.

Normally the TV and AVR should be powered on before the Vero. As you normally would not power down the Vero this is a one time step anyhow.

Um my english is not very good, but I will try to explain why 1080p is not good on my tv :slight_smile: The picture is umm… over the screen, like, I don’t see all of the Vero UI with 1080p. There is probably some sort of adjusting integrated in Vero settings which I need to do?

No setting on Vero should be used to fix that. You need to set your TV to use 1:1. I think on LG it’s called Just Scan but let me check if I find the manual for the exact setting or maybe one of the other LG C8 users can confirm faster

Ok, I did a quick search but to be honest the manual looks a bit strange. My gut feel is Picture Settings -> Aspect Ratio -> Just Scan

Thanks! I will try and report back. Grr hate work, I want to play with Vero at home now :smiley:

It was indeed a Just Scan problem. First, I lowered the UI resolution to 1080p then tried few movies that did not work yesterday with adjust frame rate. All fine. Then, I raised the resolution back to 4k, and it still worked, so… I guess it was a missmatch between the picture/screen size/format and KODI trying to adjust frame rate. Now, what are differencies between adjusting frame rate “Always” and “On start/stop”, which one is “better”?

I will not post any logs now that you helped me focus on the TV and “just scan” problems but if the problem comes back I will def. log the whole situation.

Thank you all. Really nice to see how this amazing comunity is alive and fast with helpful advice when needed. I am now gonna enjoy the shit out this little vero box that kicks apple tv’s ass with full/normal audio passtrough :slight_smile:

p.s. off topic, this is the first time I came from work to power on Vero with the remote, and don’t know how to do it? Is it designed to not be turned off manually? I just turn of the TV and AVR and let it be? will it sleep on its own? I’m a newbie… heh

Use power -> suspend rather than Shut Down.

1 Like

Most people use Start/Stop. That will only change frame rate when a video starts/stop. Always will change mid-stream if the frame rate changes within the file. Try both ways and see what works best for you.

The Vero is designed to be always on. If you turn it off, (not suspend) you need to unplug re-plug it. There is a suspend mode available. I personally never use it as the power saving is minimal.

As written before, it is recommended to keep GUI at 1080p as your TV would do better job in upscaling.

1 Like

I don’t want to start a new thread just for this quick followup question: I now keep my Vero ON at all time, but yesterday I tried to use Suspend. I set it on 30 minutes and went to work. When I came back, how I wake it up from suspend?, any button on remote will do it, or it must be something special? I tried Home, OK, arrows, nothing worked but then “something” wake it up. Don’t know what I did, maybe TV remote or AVR :slight_smile:

How it should work? suspend then ANY button on remote, or…


I’ve never used suspend, but my understanding is any key should do it. Maybe someone who uses suspend can give you a better answer.

1 Like

Yes any button on remote or via CEC will bring the Vero from suspend to normal operation. As HDMI signal is reenabled the TV might need a second to resume.

Basically I have set it up that switching off TV will put Vero into Suspend and then when I switch on TV and go to Vero Source it automatically wakes up

That is a nice feature, where can I set it up? Is this a TV setting or somewhere on Vero?

It’s on the Vero, Settings -> System -> Input -> Peripherals -> CEC Adapter -> When the TV is switched off -> Suspend

1 Like