Adjust OSMC Display to 'Fit' 4:3

At my remote camp, I’ll be attaching my RPi (3B (v 1.2) with OSMC (running KODI 20.1) and TVHeadend 4.2.8 to an older (4:3) CRT style TV. The TV is limited to ‘Composite’ cable connection. I’ve been successful in the past using an HDMI cable from the RPi through a mini (HDMI2AV) conversion box, to composite connectors at the CRT TV. However, edges of the image are outside the viewing area making navigation/viewing difficult. I am attempting to work through these features at my primary residence where I have access to internet and assorted equipment. I have downloaded, and performed the recommended alterations to the OSMC 4:3 skin. I can switch to the 4:3 skin, no problem. However, my display still seems to ‘fit’ my (16:9) monitor. How can I adjust the display to ‘fit’ 4:3?

IIRC 4:3 doesn’t need downloading anything. Can you detail what you’ve done so far?

  1. Downloaded the ‘OSMC skin v20.0.0 (June) zip file from the GitHub
  2. Renamed the file as “skin.osmc.43”
  3. Unzip folder and changed folder name from skin.osmc to skin.osmc.43
  4. Opened “addon.xml in Notepad++ (editor) and changed as follows,
  5. Changed addon id=”skin.osmc” to addon id=”skin.osmc.43”
  6. Changed name =”OSMC skin” to name = “OSMC skin (4:3 Version)”
  7. Commented out “res width=“1920” height=“1080” aspect=“16:9” default=“true” folder=“xml” /”
  8. Un-commented “!-- <res width=“1440” height=“1080” aspect=“4:3” default=“true” folder=“xml” /” →
  9. Saved the edited addon.xml to folder skin.osmc.43
  10. Created new file
  11. Moved zip file to thumb drive, and placed thumb drive in RPi
  12. In OSMC, selected Settings>AddOn Browser>Install from zip file, and imported the zip file.
    As indicated in original post, OSMC appears to switch skins when “skin.osmc.43” is selected, but the resulting image fills the 16:9 monitor. I’m not sure what I’m looking at. Are my resolution width and height incorrect? How to ‘fit’ to 4:3 screen?
1 Like

Wouldn’t you need to also change the Kodi’s UI resolution to output 720x480? Also since your using a RPi why use a converter box instead of a four pin headphone to composite cable? I think you may have to add something to config.txt to enable it but that is probably the better option. IIRC there was a thread started maybe two years ago of someone hooking up a Pi to an old TV like this. If you can find the thread it probably has some relevant info in it.

Thanks. Changing UI resolution only makes the screen (understandably) fuzzy. Does not reduce the display size. I’ll look for the string and consider the composite cable.

Sounds about right. Can you post your addon.xml (as code using the </> button), please? Maybe @Chillbo can check what you’ve done.

Can you also upload logs.

Your adjustments to the skin sound right. If setting the GUI resolution to a 4:3 one doesn’t produce a 4:3 image on your screen, the HDMI conversion box presumably doesn’t seem to recognize the output as 4:3, I’d say. Have you enabled the “Use HDMI AVI signaling” under settings/player?

Only when this is enabled, will Vero signal to the HDMI receiver that the outgoing SD resolution is to be displayed at a 4:3 aspect ratio. But I’m not sure this setting affects GUI output and not just video output.

If this doesn’t work, try and use a proper 4:3-only aspect ratio resolution (not SD) like 1280x960 (if available).

The aspect ratio is read from video metadata so behaviour with the GUI is undefined. I can get the 4:3 skin to display properly through a HDMI->VGA converter (U-Green) to a 1024x768 monitor. (once you told me how to do it :slight_smile: )