Adjusting contrast sometimes switches on subtitles

Since upgrading to K18, I notice that sometimes if I adjust contrast during playback, after I adjust the contrast, the subtitle stream in the mkv file is switched on.

As I mentioned in an old thread, contrast adjustment via the GUI preserves the new value for a title but the value is not used when initiating playback. As I run a 1080 environment for my main system and OSMC usually undershoots the default contrast with 4K files, every time I start a 4K mkv I have to re-adjust the contrast.

The day I installed K18, I noticed that sometimes this results in the subtitle stream being switched on. A bit baffled, here is a log of a playback session where this happened.

Do you have subtitles enabled by default for all videos?

My Player/Language preferred subtitle setting is “Original language”. All my mkv files are carefully pepared with either a single subtitle stream that has the default subtitle flag set to No (i.e the subtitles are switched on by the user during playback, if requested), or there is an additional subtitle stream for titles with a forced track (e.g. occasional foreign language scenes), and for this track the mkv file has a default status set for the track. With my Kodi language settings such a track is enabled by default and Kodi can then produce a seamless forced subtitle experience without always showing the main track, it’s no different to playing a disc.

All this worked perferectly on K17 and in terms of general use, it works perfectly with K18: a seamless forced subtitle experience, and full subtitles are there if I want them but are not shown by default.

However, when I adjust contrast during playback of my 4K files, I’m randomly finding that as soon as the contrast is adjusted, the subtitle stream is enabled even though the subtitles were not showing before I adjusted the contrast. I have not tried this with 1080 mkv files as I never need to adjust the contrast on those.

This is definitely a K18 issue, as I had extensive experience of adjusting contrast with one of the late K17 OSMC builds, and this random enabling of subtitles never happened.

Do you have Kodi on another device, and if so, can you also reproduce it on this platform?

The only devices I have that can play 4K mkv’s are Vero’s. I will see if the problem can occur with blu-ray mkv’s on the Vero, and if so, will check out my OSMC and LE Pi’s.

Neither my OSMC Pi nor my LE Pi have options for adjusting contrast during playback (at least that I can find).

I was able to produce the same problem with a blu-ray-sourced mkv on the Vero, quite peculiar.

It’s great that the new OSMC release has fixed the issue where Contrast adjustment doesn’t stick on re-starting playback. This is very helpful for me. However, as noted previously, there is an odd issue with the current and previous release regarding subtitles. All my mkv rips have a subtitle track, with the default flag unset for the subtitle track unless it happens to be a forced track. That way I get my forced subs when they are needed, but otherwise there are no subtitles unless actively switched on.

Anyway, when I adjust contrast during playback for titles that have never had their contrast adjusted before, Kodi is switching on the subtitles the moment the contrast is adjusted. This seems to be a one-time thing. Once the subtitles have been disabled, adjusting contrast does not reactive them.

It occurs to me that this ought to be a very simple thing for others to test? I can post a log if helpful.

Do you experience this on other platforms with Kodi v18.4, ie PC?


Thanks for the suggestion. Just installed the Windows version of Kodi 18.4 on my PC and it has the same problem. The moment I adjust contrast, the subtitle track with the unset Default flag is switched on. Also happens if I adjust brightness. Can this be reported anywhere?

It would be best to report this on the Kodi GitHub issue tracker. I will see if there’s a trivial fix for this.


Thanks @ac16161. I’ll pick it up on the Kodi side.