Advanced Mame Launcher Setup

Ok. I have banged my head against the wall for a while, as some answers seem harder to come by. Hopefully, you guys can help me figure this out. I have read this page - Advanced MAME Launcher - MAME frontend for Kodi - tons of times. It slowly started to click, and I think I have most things correct; however, Check AML configuration gives the following page -
Operation Mode Retroarch MAME 2003 Plus (Chose this because I couldn’t find anything about a “vanilla mame” unless that just means basic MAME 2003 etc)
Software lists disabled (Didn’t see how to enable them, but it must be on the configure page)

MAME executable
ERR MAME ROM Path not found
ERR Retroarch executable not found
ERR Libretro directory not found
ERR MAME 2003 Plus XML not found

MAME optional paths
WARN MAME CHD Path not found
WARN MAME Samples Path not found

NAME assets
ERR MAME Asset path not found

INI/DAT files
ERR MAME INI/AT path not found.

ALL of these paths have been defined in configuration. They all reside on a QNAP NAS with guest privileges enabled for RW. I think this is my minor issue. My MAJOR issue is understanding the MAME software itself. I AM NOT talking about ROMS. I saw another thread get a little testy on the subject, so I want to be clear that I am only talking about the Retroarch software. Vero is Linux but OSMC is a form of Windows, so which version is supposed to be installed? And more importantly, how do you even install it? I tried installing it on Windows and moving the executable over the QNAP, but there are still tons of other files associated, such as DLL’s as well as the Libretro cores that allow the various ROM’s to operate. So bottom line, what does “installing MAME” really look like? I know that the configure file must point the the actual executable, but what else goes there and from which OS version?

​​​​​​​TIA

This is hard to answer right out of the box, from my stand point you got two solutions, RetrOSMCmk2 an addon that close Kodi and starts a version of RetroPi instead. Depending on configuration you can make it switch between them (never tried that myself yet). Any case, that won’t help Adv.MameLauncher, since that’s a Kodi addon. Then you need Kodi.game, which I’m trying to build for the vero, out of 130-ish emulators I got 80-ish build for Vero. But many still Sadface och reboots the Vero, due to missing/erroneus filerights/folders. So far I’ve only had a chance to test about 10 of 80 emulators.

1 Like

But this AML add-on makes it sounds like it’s soooo simple. lol. Let’s start simple. What REALLY is the Vero? It’s a processor board running Linux with an OSMC shell? Is that accurate?

So this Retropie actually runs within OSMC. Is Vero running on a Raspberry Pi board? That sounds just a completely different plugin, where AML would not even be used. Is that correct? From a power aspect, this AML seems quite impressive. I like the fact that it seems to be able to run off a completely different drive, like a NAS. Since the internal storage of a Vero is very small, this would offload most of the data to a different source, and a NAS would be excellent as long as the bandwidth does not impact performance, which it shouldn’t as long as it has a good wired backbone. I’m sure this could still be an issue with more modern ROMS.

  1. Vero has the same processor family as the pi3, just a bit more beefed. The GPU and most of the other components are not pi compatible. Hens the MK2 for Vero of the RetroPi adaption for OSMC, which only ran on RBPs.

  2. RetrOSMC, was the lovechild of one of the mods. It’s a script that compiles most of RetroPie source code, to make it OSMC compatible. Then Hissing shark stepped it up a notch and fiddle with the scripts and then started adding stuff to Vero4k exclusively, like process switching between Kodi and Emulation station.

  3. I hope to get Vero4k kodi.game builds running again sometime mid or late this coming week. (Monday starts the week here in Sweden).

Counter question: Do think you would be interested to help test a bunch of compiled but not tested emulators and games?

Always willing to help. As I read through some more threads, it seems you and HissingShark are the guys doing some great work on this. It also gave me a little insight… I think. The Vero, being it’s own animal needs something compiled specifically for it. Even though this AML is available by default on the Vero, it seems that it is really intended to look for a MAME executable on the same machine, which in most cases is a Windows machine running KODI. With this setup the instructions make a hell of a lot more sense, since the folders /home/kodi would be much more accessible and with most likely a significant amount of space. So as cool as this AML looks, I don’t see any way to make it compatible unless maybe the entire Vero points at a separate Windows machine running the MAME emulator, but that would pretty much defeat the point.

I installed the RetropieMK2 last night. It was a significant amount of code going through there for sure. I saw that it has to run completely separate from OSMC, so I am going to look further today to see how you actually launch it from the Vero.

Have you had any experience in connecting various controllers with USB adapters? I bought several versions the other day to see what I could find that worked. So far I received the Nintendo classic one and an N64 one. I believe I have a PSX, Dreamcast, and PC 15 pin on the way too.

Where to begin…

Advanced Mame Launcher, it’s a Kodi addon that expects kodi.game. Sam used to send a limited amount of working emulators back in 18.x. I don’t remember what made it so, but those libretto cores got left out when 19 was released. I’m trying to catch up.

If I remember correctly there is 2-3 Mame version that compiled last time I built it. Along with NES, SNES, Sega Master and Genesis, A bunch of, for me unknown, 8 bit computers. Well some known too, but others really known too, but the seems to be issues with bios file etc.

But to comeback to AML, it should work with my commin build.

Now you might think, why have mk2 when you have Kodi.game,? Well the answer is simple 3D accel.

Ok. Let me know when you’d like to test it. It seems to have a lot of potential. I did see someone post somewhere that AML can’t work in conjunction with a NAS, so if there is anything that can be done to allow that, I think we could make this incredibly powerful.

What about controllers? I see some people are connecting various units over bluetooth, but it would be cool to actually use original controllers for the various games. The two I have so far are from Amazon. They are all from Amazon. The Nintendo ones don’t really have a brand, but they were the only ones that were for the Nintendo Classic Mini and have wireless, USB, and rechargeable batteries. It says it is compatible with Windows, Mac, and Pi. The other is a Mayflash for N64 but only mentions Windows.

So mk2 uses 3D acceleration, as in OpenGL?

Controllers, well there I feel out of my comfort zone =)… Been using a wired 360 controller, until recently when I got a One wireless connected. Which was a feat on it’s own. In kodi is rather simple, when you are doing controllers in Mk2, that another jungle to navigate, sure RapspberryPies wiki is a good source of info, but not for the novice user sometimes.

Seriously, been focusing so hard on Kodi.game lately that actual game has had to take the back seat. That is why I need some testers.

3D Accel = GLES2 (if i remember correctly), which is accessible from SDL. Enough for N64, but dont expect fireworks :slight_smile:

I have a rudimentary understanding of a lot of this. I’ve tried several controllers - NES Classic, PS4, Switch (Gamepad style). None were recognized at all by the software, where it says press and hold a button on your controller to enter setup. I’ve done some Arduino stuff as well as lots of serial comm (Yeah, I know. Old stuff lol, but keep in mind the AV world used to be decades behind the computer world). I’ve never bothered with USB up to this point. Trying to understand at the most basic level. For any device to work with USB, the device itself would have to have some sort of firmware that would allow it to transmit a code/address for a button press that the OS would understand. Would you agree? From there the OS/Software itself would then translate those addresses/codes to a functional button press. Then those button presses could be mapped to configurations for a controller or game setup. Is this all accurate? So then if none of these are recognized, then the first trick must be to find a hardware gamepad that is recognized by the OS. Until then coding something like found on this page seems pointless. RetroArch Controller Configuration - RetroPie Docs

Is all this accurate or should it be more straightforward than it seems?

Where are you at with this?

Well, there has been issue after issue. Large family and the 7 year old was investigated for autism-spectrum during the last 14 days. So I haven’t had the time i wished or even expected to have. But Just as you posted this I’m doing a new build with the latest OSMC source and my patches. It’s been running for like 3 hours and then my lovely son, shut down the terminal emulator. Lucky I got ccache enabled, so i now started (20 mins ago) a new build, under screen.

Sorry to say, seems i have to restart this build. A family member caused a fuse to blow. Eg. The build got rudely disrupted.

1 Like