Advanced video resolution rules


Latest Vero4k here, OSMC March 2022.03-1 Kodi 19.4

I have a big issue with Youtube videos from the Youtube plugin, many of them are like this for example: Am-Vp9 3840X1920 px 2.00:1 23.976

Deinterlace method hardware

This specific frame rate on 3840X1920 and pretty much all other resolutions I tried causes very bad audio skips and basically video is unwatchable unless I manually set to a resolution with 59.94 frame rate

All 23.98 resolutions I already blacklisted. But there is one left, 4096X2160p @ 23.98 and every stupid 23.98 video, even very low res, will now auto switch to it! I cannot remove this resolution, because I often watch 4k HDR movies that need it. My TV cannot do 4096X2160p @ 59.94 so the only options left is to either change manually all the time which is very annoying or give up my 4k tv max resolution and watch every 4k content on max 3840X2160p 59.94

Is there any way to modify this behaviour with some advanced configuration from the console, etc? Any ideas much appreciated!

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks a lot Sam!

I did exactly as instructed. This is the log:

There’s bug which means a 4k resolution video with a 44.1k PCM soundtrack doesn’t play well. Workaround is to set audio output to Fixed with 48ks/s.

With that 3840x2160p24 should play fine. Please see if that solves the problem or post logs again for a problem video.

Ahh, that solved the problem, on fixed 48Khz now those videos play like a charm, I enabled all 23.98 configurations. Many thanks @grahamh !